cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
402
Views
0
Helpful
1
Replies

PPTP dial-in over a PPPoE dial-out

marianogarcia
Level 1
Level 1

Hi.

How can i do to perform a dial-in server for remote workers using a PPPoE encap in a DSL/ATM enviroment???

Here is my testing config.

sh run

Building configuration...

Current configuration : 1826 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

logging queue-limit 100

!

ip subnet-zero

!

!

!

ip dhcp pool LOCAL

network 172.26.0.0 255.255.0.0

default-router 172.26.0.1

dns-server 80.58.61.250 80.58.0.33

!

ip audit notify log

ip audit po max-events 100

virtual-profile if-needed

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

vpdn-group 2

! Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

!

!

isdn switch-type basic-net3

!

!

no crypto isakmp enable

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 8/32

pppoe-client dial-pool-number 1

!

!

interface BRI0

no ip address

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

!

interface FastEthernet0

ip address dhcp

speed auto

no cdp enable

!

interface Virtual-Template1

ip unnumbered FastEthernet0

ip nat outside

ip mroute-cache

peer default ip address dhcp

no keepalive

ppp encrypt mppe auto

ppp authentication ms-chap callin

ppp chap hostname prueba

ppp chap password 0 prueba

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

ppp authentication chap callin

ppp chap hostname adslppp@telefonicanetpa

ppp chap password 0 adslppp

!

ip nat inside source list 2 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

ip http secure-server

!

!

!

access-list 1 permit any

access-list 2 permit any

access-list 102 permit tcp any any established

access-list 102 permit udp any any gt 1023

access-list 102 permit icmp any any

no cdp run

!

!

line con 0

line aux 0

line vty 0 4

login

!

no scheduler allocate

end

Dial-out aka. dialer1 works fine!!!

but not dial-in.

1 Reply 1

marianogarcia
Level 1
Level 1

sorry, i'm using a cisco1721.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: