Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem loading Java (rdp) and Citrix (ica) on Cisco ASA

Hello !!

I have an Cisco ASA 5505 running ASA OS version 8.2 The problem is when I log on to ASA and when I try to open JAVA RDP terminal server Client less SSL, than the JAVA screen loads but it is small size, it is not possible to resize at all, so I am not able to use it at all.

I tryed to define the link like below :

10.48.24.3/?geometry=1024x786&bpp=16

and only

10.48.24.3

But the same problem :(

also I can`t get Citrix JAVA ICA applet working either, I did exact as Cisco described in the DO IT SELF .doc file, but no way. I think it must be a bug, I can`t belive that I did it wrong. The link for Citrix I used is below :

10.48.24.5/?DesiredColor=4&DesiredHRes=1024&DesiredVRes=768

But it will not work.

Please is there someone who got the RDP and CITRIX Java applet working on the ASA ??

Thank You !!

Best regards

8 REPLIES
Cisco Employee

Re: Problem loading Java (rdp) and Citrix (ica) on Cisco ASA

Hello,

the gemoetry commands you are using at the end of the RDP URL appear to be correct - though I'm not sure about the "bpp" you have at the end.

You may want to try uninstalling and re-installing the rdp plugin and verify that you are using the bookmark list that you are modifying.

--Jason

New Member

Re: Problem loading Java (rdp) and Citrix (ica) on Cisco ASA

Hello !!

Thank You for reply !!

I really tried everything with RDP, but no way, it is the same whole time.

BUT I just got Citrix ICA (Jica), it is working just fine now. Cisco have described wrong in the DO IT SELF .doc file.

So the RDP is still the same :( must be a bug, the Java windows is still small.

New Member

Re: Problem loading Java (rdp) and Citrix (ica) on Cisco ASA

How was the DO IT SELF.doc incorrect? Would you be able to post the changes you did to get it to work? - THanks

New Member

Re: Problem loading Java (rdp) and Citrix (ica) on Cisco ASA

Hello,

Sorry, I should post it right after I fixed it, but I was to busy with RDP problems, and I still have not found solution for it.

But back to Citrix Jica. This is what Cisco said in the DO IT SELF .doc file :

How to deploy the Citrix Plug-in

1. Download the citrix java client from Citrix site

http://www.citrix.com/English/SS/downloads/details.asp?dID=2755&downloadID=20731&pID=186

2. Extract the JICA-configN.jar and JICA-coreN.jar files , and then add them to the Cisco ica-plugin.zip archive file using WinZip

3.Import the ica-plugin.zip into the ASA using ASDM or CLI

i.e. #import webvpn plug-in protocol ica tftp://server/ica-plugin.zip

4. Establish a SSL VPN Clientless session and enter the bookmark/url for the citrix server:

Note: It's recommended that you use url parameters to make for more optimal viewing/resolution.

ica://10.56.1.114/?DesiredColor=4&DesiredHRes=1024&DesiredVRes=768

5. Refer to the citrix admin guide for further instructions and parameters:

Link to the citrix admin guide http://support.citrix.com/servlet/KbServlet/download/6284-102-12977/ICAJava.pdf

6. Please refer to your Citrix EULA to ensure it grants you the rights and permissions to deploy the client on your web servers.

______________________________________________

But when I did it step by step as Cisco described, it did not worked at all.

So below is what I did and it work just fine now.

Please in order to make Jica working do following step by step:

1. download the Jica (ICA-Java) Components from Citrix web site:

http://www.citrix.com/English/SS/downloads/details.asp?dID=2755&downloadID=20731&pID=186#top

2. download Citrix ICA-Plug-In from Cisco

ASA software page:

http://www.cisco.com/cgi-bin/tablebuild.pl/asa

3. when both of these archives are downloaded than do following

unpack the .zip archive named JICAComponents.zip extract following files from this archive:

- cryptojN.jar

- JICA-audioN.jar

- JICA-browseN.jar

- JICA-cdmN.jar

- JICA-clipboardN.jar

- JICA-configN.jar

- JICA-coreN.jar

- JICA-Printer.jar

- JICA-SeamlessN.jar

- JICA-sicaN.jar

- JICA-zlcN.jar

- JICAEngN.jar

- sslN.jar

4. now when these files are extracted in one folder, than open the archive named ica-plugin.zip and add all these files named above on to this ica-plugin.zip file.

5. when this is done, than upload this ica-plugin.zip on to Cisco ASA and add it as ICA Plug-IN on the Cisco ASA.

6. Than create the ICA link on the PORTAL BOOKMARK Template as following:

10.48.24.5/?DesiredColor=4&DesiredHRes=1024&DesiredVRes=768

7. Now we can test it and the Citrix will be loaded trough Clientless SSL.

New Member

Re: Problem loading Java (rdp) and Citrix (ica) on Cisco ASA

So as you see we need to add the rest of the Jica components or otherwise the Citrix will not be able to load it self.

The file JICA-SeamlessN.jar is the most important, without this you will not be able to load the published desktop or application.

Best regards

New Member

Re: Problem loading Java (rdp) and Citrix (ica) on Cisco ASA

Hello,

I followed the detailed explanation above.

When I double click bookmark, it comes to the point where is shows "Checking credentials" and then it fails with the error "sun.misc.ServiceConfigurationError".

Any idea?

Thanks

New Member

Re: Problem loading Java (rdp) and Citrix (ica) on Cisco ASA

hello,

It worked correctly after I upgraded the Java runtime to the latest version (1.6.0).

Regarding the RDP plugin problem, there is a new RDP plugin available on Cisco download site since a couple of days that corrects the problem.

New Member

Re: Problem loading Java (rdp) and Citrix (ica) on Cisco ASA

Hi

Thank You for reply, i have just installed it and tested. Now I like the way they did it full screen support too NICE !

But now I noticed one problem with Citrix JICA plug-IN. It work, but allways when you access it FIRST time when java tries to LOAD in it hangs, on that orange color java window, than when I use HOME button on ASA vpn and clicks again on the Citrix URL than java loads as it should.

I hope that Cisco will speak to Citrix about it...

Thank you again !!

Best regards

3128
Views
5
Helpful
8
Replies