Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Problem using PORT REDIRECTION with PIX 6.0(1)

I am trying to setup a pair of DNS services on a

single 'box'. This would allow me to have an

INTERnet DNS and a INTRAnet DNS running on a single

server.

I thought I could accomplish this by setting the

INTRAnet function to use port 53, and the INTERnet

function to use port 2053.

Then on my PIX 6.0(1) firewall located at my network

boundary, I coded the following statement:

static (inside,outside) udp 66.123.66.123 domain 10.1.2.3 2053 netmask 255.255.255.255 0 0

Workstations using 66.123.66.123 as their DNS server

do get 'redirected' to the 2053 port O.K, but

the response to the query goes back out the firewall

on port 2053 back to the workstation. At which point, the workstation 'ignores' it become it is

expecting a response back from 'source = port 53' and not 2053.

Is there some magic I can work here, or am I stuck until it is fixed 'in the next release'?

Thank (in advance),

Dick Schulz

1 REPLY

Re: Problem using PORT REDIRECTION with PIX 6.0(1)

Since there has been no response to your post, it appears to be either too complex or too rare an issue for other forum members to assist you. If you don't get a suitable response to your post, you may wish to review our resources at the online Technical Assistance Center (http://www.cisco.com/tac) or speak with a TAC engineer. You can open a TAC case online at http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

84
Views
0
Helpful
1
Replies
CreatePlease to create content