Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with PPTP server on Cisco 851

Hi, All!

Sorry for my bad english =)

I have a small network 10.15.0.0 /24

Cisco is a gateway and DHCP server for internal network.

ISP link is directly connected to fa4

I've been requested to configure PPTP server on this device for remote users

Config is below:

sh ver:

Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(4)T8, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Sat 11-Aug-07 03:29 by khuie

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

config:

aaa new-model

!

!

aaa authentication login default local

aaa authentication ppp vpn local

aaa authorization console

aaa authorization exec default local

aaa authorization network vpn local

!

ip subnet-zero

ip dhcp excluded-address 10.15.0.1

ip dhcp excluded-address 10.15.0.2

!

ip dhcp pool DHCPPOOL

import all

network 10.15.0.0 255.255.255.0

default-router 10.15.0.1

dns-server 10.15.0.2 10.15.0.1 195.112.*.*

domain-name wr

lease 2

!

ip cef

ip domain name NAMETHERE

ip name-server 195.112.*.*

ip name-server 195.112.*.*

vpdn enable

username vpn password 0 test

username vpn aaa attribute list vpn

interface FastEthernet4

description WAN interface

ip address 195.112.*.* 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Virtual-Template1

ip unnumbered Vlan1

peer default ip address dhcp-pool DHCPPOOL

ppp authentication ms-chap

!

interface Vlan1

ip address 10.15.0.1 255.255.255.0

ip broadcast-address 10.15.0.255

ip nat inside

ip virtual-reassembly

!

ip default-gateway *.*.*.*

ip classless

ip route 0.0.0.0 0.0.0.0 *.*.*.*

Remote user's can connect to this network, but they obtain wrong tcp\ip parameters.

example:

testpptp - PPP:

DNS-suffix . . :

description . . . . . . . . . . . . : WAN (PPP/SLIP) Interface

physical address. . . . . . . . . : 00-53-45-00-00-00

Dhcp enable. . . . . . . . . . . : no

IP-address . . . . . . . . . . . . : 10.15.0.19

Subnet Mask . . . . . . . . . . : 255.255.255.255

GateWay . . . . . . . . . . :

DNS-servers . . . . . . . . . . . : 195.112.*.* 195.112.*.*

So they obtain correct ip address, but incorrect DNS server, gateway, subnet mask.

And question is WHY? :)

I hope i wrote it correctly and clearly.

Thanks

1 REPLY
Bronze

Re: Problem with PPTP server on Cisco 851

Can you see the translation for GRE. Could you provide the details of sh ver, sh access-list and show log

390
Views
0
Helpful
1
Replies