Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with Tftp and Asdm install

Greetings,

When I tried to install asdm-502.bin to my newly upgraded box to 7.02 I get and the following error (This error is not new to me. It happened also when I tried to upgrade from Pix635 to Pix702 from Monitor,. Is there a fix. Thanks.

pix# copy tftp://192.168.1.20 flash:/asdm-502.bin

Address or name of remote host [192.168.1.20 ]?

Source filename [asdm-502.bin]?

Destination filename [asdm-502.bin]?

Accessing tftp://192.168.1.20 /asdm-502.bin...

%Error opening tftp://192.168.1.20 /asdm-502.bin (No such device)

When I tried to ping the 192.168.1.20. I get no success.

8 REPLIES
Gold

Re: Problem with Tftp and Asdm install

well you mentioned you can't ping 192.168.1.20 from the pix, so it means the network connectivity is not there. either they are not connected physically or the ip are not right. another possiblity is that the .20 host has software firewall installed, which blocks all inbound traffic.

New Member

Re: Problem with Tftp and Asdm install

jackko,

Thanks for taking the time.

About connectivity. I was able to install 7.02 from Monitor with no problem.

This problem is somehow related to installing 7.02. Because after I installed the 7.02, I couldn't tftp from Monitor or from #.

I replaced my .20 with an old 98 machine (no firewall) = still the same.

I did a wr erase and reloaded 635 instead of 7.02, no problems with tftp either from Monitor or #!!!

Gold

Re: Problem with Tftp and Asdm install

you mentioned "Because after I installed the 7.02, I couldn't tftp from Monitor or from #." just wondering if you were trying to downgrade from v7. if so, the procedure is a little bit different. e.g. you need to use the command "downgrade".

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a00804708d8.shtml#t6

New Member

Re: Problem with Tftp and Asdm install

Yes, you are right the procedure is different for downgrading, that is if you have the old file in the flash by using (pixfirewall# downgrade flash:/image_old.bin).

Otherwise you will have to dig it with tftp. I am aware of it because I run into it and had to take another shortcut since before I upgraded to 702 I deleted my flash :).

But my problem showed up after I installed the 7.02 and wanted to install the Asdm-502.bin.

Gold

Re: Problem with Tftp and Asdm install

please excuse me for misunderstanding the issue.

i just did the install from the lab and it works fine. assuming you've verified the network connectivty between the pix and the tftp server, as well as the tftp services availability, then there maybe a bug with the os. i guess the only way is to open a case with cisco tac.

New Member

Re: Problem with Tftp and Asdm install

Jakko,

Today was my lucky day.

1- I deleted the flash on both

2- I installed from Monitor the Pix635.bin, then the 302 pdm from the # on both.

3- did my config and synched w/failover

4-I shut down my primary

5-On my secondary (the one that wouldn't connect from Monitor or # after upgrade to 702) I Did a "copy tftp flash" to upgrade from pix635 to pix702. It went fine

3-Reloaded, then did a "copy tftp flash" to upgrade the pdm to asdm-502 and it worked at my surprise.

4-I switched it off and did the same thing to my Primary. And no problem there as I was anticipating.

So I am all up. Asdm502 interface is much better.

Thanks for the time.

Cisco Employee

Re: Problem with Tftp and Asdm install

If you are facing issues with PIX OS or PDM / ASDM upgrades via TFTP and at the same time if you have Internet connectivity from the PIX, you can use the following command to upgrade your PIX via HTTP:

PIX OS Upgrade:

pixfirewall(config)#copy http://:@198.133.219.27/cisco/ciscosecure/pix/.bin flash

PDM Upgrade:

pixfirewall(config)#copy http://:@198.133.219.27/cisco/ciscosecure/pix/.bin flash:pdm

ASDM Upgrade:

pixfirewall(config)#copy http://:@198.133.219.27/cisco/ciscosecure/pix/.bin flash

Note: For this procedure to work you need a valid CCO ID with software download permission.

Cheers...

Prashant Chauhan.

New Member

Re: Problem with Tftp and Asdm install

That's great.

I'll keep that in mind.

Thanks.

274
Views
5
Helpful
8
Replies
CreatePlease to create content