Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Problems with the new VPN API 4.7

Hello

I wish to use the new API 4.7 released by Cisco at 16-SEP-2005

I have very big problems implementing the API into a MFC project in visual studio 2003 .NET

I get a lot of linking errors (unresolved external symbols) LNK2019, i have included the Api.lib in linker options in my project.

Is there a step by step instruction how to use the API in a new MFC project (what options do I need, what includes do i need)?

I have used the old API (4.6.00.0045) with success, but i would like to make my new projects with the new API.

The compiler output can be seen at:

http://www.staff.hum.ku.dk/rbj/compileroutput.txt

Thank you in advance

Rasmus Brown Jensen

1 REPLY
Silver

Re: Problems with the new VPN API 4.7

For cisco call manager option,configure the following

Enable the option Enable Calling Party Number Modification for the CER JTAPI user.

Create a 911 route pattern for the default ELIN with the Calling Party Transformation Mask set to the default ELIN.

Create a 911 route pattern for the other ELINs with the Calling Party Transformation Mask set to one of the ELINs.

For CER configuration, perform these steps:

Enable the option Calling Party Modification in the CER Group Settings page.

Configure the Emergency Response Location (ERL) with the route pattern or ELIN patterns.

298
Views
0
Helpful
1
Replies
CreatePlease to create content