Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS and VPN with a cable or dsl connection

Anyone have any tips or examples on configuring QoS for VPN while using cable or dsl services? The bandwidth is always changing, so it is hard to specify a certain limit. Can you simply define higher priorities for certain traffic without having to define the actual bandwidth?

Dan

7 REPLIES
Silver

Re: QoS and VPN with a cable or dsl connection

Defining QoS will only effect traffic leaving your router and have no effect on the Internet whatsoever. I have cable modem with 384Kbps upstream, so I traffic shape outbound to this speed to prevent drops in the cloud. I also use an IP phone at home, so I give this traffic priority leaving my router. Again, this only helps locally at my house on the first hop of the trip. If doing VPN, it can also help once you've arrived at the destination gateway and the traffic is decapsulated.

New Member

Re: QoS and VPN with a cable or dsl connection

Thanks for the reply. I realize that this is the situation, I was wondering if you could post an example of your config?

Thanks,

Dan

Silver

Re: QoS and VPN with a cable or dsl connection

Pixs have no capabilities for QoS or traffic management. My config is from an IOS router. Is that what you're interested in?

New Member

Re: QoS and VPN with a cable or dsl connection

Yes.

THanks,

Dan

Silver

Re: QoS and VPN with a cable or dsl connection

class-map match-any ipt

match protocol rtp audio

match ip dscp ef

!

!

policy-map child-intf00

class ipt

priority 28

policy-map intf00

class class-default

fair-queue

random-detect dscp-based

shape peak 384000

set ip dscp ef

service-policy child-intf00

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip access-group outside-net in

no ip unreachables

no ip proxy-arp

ip nat outside

ip inspect Home out

service-policy output intf00

ip route-cache flow

load-interval 30

speed 10

half-duplex

crypto map fe00

New Member

Re: QoS and VPN with a cable or dsl connection

Great, I appreciate the help. I can't wait to try this out!

So in this config you are dedicating 28000bps to voip?

Thanks,

Dan

Silver

Re: QoS and VPN with a cable or dsl connection

Yeah. That's enough for one G.729a phone call. Officially, it's 24Kbps per call, but you have to allow for Layer2 overhead. For Ethernet, it should probably be a little higher. I think I'm going to raise mine to 32K.

274
Views
0
Helpful
7
Replies
CreatePlease login to create content