Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Question regarding tunnel configuration example

Please have a look at this example:

http://www.cisco.com/univercd/cc/td/doc/product/core/7100/swcg/6342gre.htm#xtocid50

hq-sanjose

interface Tunnel0

bandwidth 180

ip address 172.17.3.3 255.255.255.0

no ip directed-broadcast

tunnel source 172.17.2.4

tunnel destination 172.24.2.5

crypto map s1first

ro-rtp

interface Tunnel1

bandwidth 180

ip address 172.24.3.6 255.255.255.0

no ip directed-broadcast

tunnel source 172.24.2.5

tunnel destination 172.17.2.4

crypto map s1first

Why does the tunnel interfaces have different networks allocated to them 172.24 & 172.17 ? Should they not have just one network like 172.24.3.0 /30 allocated to both sides of the tunnel ?

Tried to simulate sometning similair in a lab using the loopback addresse of each router "ip unnumbered Loopback0" on both sides but it does not work. The tunnel interface status is up up but ospf does not 'learn' about the networks of the other router and no traffic is transported through the tunnel.

2 REPLIES
Bronze

Re: Question regarding tunnel configuration example

Yes, for what you are tying to do, the tunnel interfaces should be in the same network (like 172.24.3.0/30). After doing that try turning off the crypto map stuff and seeing if OSPF will come up (remember to do someting like network 172.24.3.0 0.0.0.3 area 0 in the OSPF config!). If that works, then turn on the crypto map and make sure it continues to work. If the crypto map makes it break, make sure that you are matching ospf packets in the match ip address bit.

Good luch, and always fun to help a fellow ZA.

--Warren.

Community Member

Re: Question regarding tunnel configuration example

Warren, thanks for the advise.

I got the tunnel working using a single subnet for both sides of the tunnel, this was on IOS 11.1(24). I could not get the cisco example to work though, I upgraded to IOS 12.0(22) and only then did the cisco example work. So it looks like it is very much dependent on the IOS version.

I still dont really understand the example as it does not make sense to me.

Next step is to get a CLNS tunnel working.

Where you originally from Warren ?

Thanks

Reon

196
Views
0
Helpful
2
Replies
CreatePlease to create content