Cisco Support Community
Community Member

Remote desktop through VPN


I have a PIX 501, the VPN is working now. I can establish my VPN connection, but i can't access the servers on the other side. I need to do remote desktop connection and Web(atleast).I think the problem is with my access-list access-group, maybe my route too. Here's what i have now...can anyone help me out please?

access-list acl_out permit icmp any any

access-list 101 permit ip

access-list 102 permit ip

global (outside) 1 interface

nat (inside) 1 0 0

access-group acl_out in interface outside

If you need more info let me know.


Re: Remote desktop through VPN

Can you post your full configuration please (taking out any sensitive info)

Thanks / Jay

Community Member

Re: Remote desktop through VPN

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password ********** encrypted

passwd ********** encrypted

hostname PIX


fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69


access-list acl_out permit icmp any any

access-list 101 permit ip

access-list 102 permit ip

pager lines 21

icmp permit any outside

mtu outside 1500

mtu inside 1500

ip address outside pppoe setroute

ip address inside

ip audit info action alarm

ip audit attack action alarm

ip local pool vpnuser

pdm location inside

pdm location inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0 0

access-group acl_out in interface outside

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

fragment chain 1

sysopt connection permit-ipsec

crypto ipsec transform-set myset esp-3des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash md5

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

vpngroup vpn3000 address-pool vpnuser

vpngroup vpn3000 idle-time 1800

vpngroup vpn3000 password ********

telnet timeout 5

ssh outside

ssh timeout 5

console timeout 0

vpdn group pppoe_group request dialout pppoe

vpdn group pppoe_group localname **********

vpdn group pppoe_group ppp authentication pap

vpdn username ********** password ********* store-local

dhcpd address inside

dhcpd dns

dhcpd lease 1048575

dhcpd ping_timeout 750

dhcpd auto_config outside

dhcpd enable inside

username user01 password ********** encrypted privilege 15

terminal width 80

Re: Remote desktop through VPN


try adding

nat (inside) 0 access-list 102


Re: Remote desktop through VPN

also apply "vpngroup vpn3000 split-tunnel 101"

Community Member

Re: Remote desktop through VPN

Great, thanks for the help guys, i'll try that out tomorrow, i'll let you know the results.

Thanks again

CreatePlease to create content