Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Router fastetthernet interface setting behing a PIX

How should I configure my router fastetehrnet interface where it is connected to the outside of the PIX.The PIX is configured Obtain DHCP automatically

on the outside interface because I m using an ISDN line which do have any fix IP address. provide from my ISP.Pls advise.

4 REPLIES
Cisco Employee

Re: Router fastetthernet interface setting behing a PIX

It'll be your router that gets the DHCP address from the ISP, not the PIX. You'll have to create a small two-host network in between the inside of the router and the outside of the PIX, point the default gateway on the PIX to the router's interface, and add a static route on the router for your internal network pointing to the PIX. You then have to decide whether to NAT on the PIX or on the router, or both. In this scenario it's easier to NAT on the router.

New Member

Re: Router fastetthernet interface setting behing a PIX

Yes,my router will get the DHCP address from the ISP for etc dialer1 interface.

I will do a' IP route 0.0.0.0 0.0.0.0 pix_inside_interface_ipaddress' on the router.On the outside interface of the PIX I will choose the option of USE DHCP(Obtain default route using DHCP) from the 3 options of the outside interface version 6.2.I will choose my pix to do the NAT.

So the big question lies here,what setting for etc IP address? do I need to configure on the fastethernet port of the router connecting back to the outside interface of the PIX?Pls advise.

Cisco Employee

Re: Router fastetthernet interface setting behing a PIX

No, no, don't do the route command on the router, you need to set the default route on the router to point out the dialer1 interface. You need to create a small 2 host network in between the PIX and the router, like this (assuming you have a 10.0.0.0 network inside the PIX):

10.0.0.0/8--(inside) PIX (outside)--192.168.1.1------192.168.1.2--router -- Internet

So the PIX outside interface gets a 192.168.1.1 IP address, NOT a DHCP address cause there's no DHCP server in between the router and the PIX. The router gets a 192.168.1.2 on its inside interface.

On the PIX, do the following:

> ip address inside 10.1.1.1 255.255.255.0

> ip address outside 192.168.1.1 255.255.255.0

> static (inside,outside) 10.0.0.0 10.0.0.0 netmask 255.0.0.0

> route outside 0.0.0.0 0.0.0.0 192.168.1.2

On the router you'll have something like:

> ip route 0.0.0.0 0.0.0.0 dialer1

> ip route 10.0.0.0 255.0.0.0 192.168.1.1

> int fastethernet0

> ip address 192.168.1.2 255.255.255.0

> ip nat inside

> int dialer1

> ip address dhcp

> ip nat outside

> ip nat inside source list 1 interface dialer1 overload

> access-list 1 permit any

The PIX doesn't do any NAT'ing in this case, that's all done on the router.

New Member

Re: Router fastetthernet interface setting behing a PIX

Ok ,thks ,for Cisco router it works. beatifully.How about if i'm using ADSL(no fixed IP address) connection with a modem dialing up and there is a different kind of ethernet broandband router sitting behind doing NAT and dynamic routing to the LAN.The 3rd party router was unable to set the static IP routing pointing to the outside interface.Any advise or I need to use the funtion of PPoE and how should I configure it?

93
Views
0
Helpful
4
Replies
CreatePlease login to create content