Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

router no connection to 10base modem

My 2600 router won't accept a connection to my old speedtouch home pro adsl modem and I wondered if I was doing something wrong. or is there a way to get the two to talk. The speedtouch modem has a 10Base ethernet socket on the back and works fine when connected to a network hub or a PC. The 2600 router also works fine when connected to other devices but if I connect either a crossover cable or a patch cable between Fastethernet0/1 and the speedtouch 10base modem socket neither device lights up.

Someone told me I may need to set the router interface to overcome this but I don't know the commends to do this, and I'm not sure what type of cable I should be using. Thanks for any help.

  • Other Security Subjects

Re: router no connection to 10base modem

Hello Anthony,

The two command you have to set in router interface are "speed" and "duplex". You should set the speed to 10 and duplex to full or half (try both, wait for a couple of seconds untill the link states comes up). Setting as "auto" might work, but the better way is to hardcode it.

The place where you should type these commands are


#configure terminal

(config)#interface "your interface"

(config-if)#speed 10

(config-if)#duplex "value"


New Member

Re: router no connection to 10base modem

thanks for your reply. I tried the commands you gave but the router and modem will still not talk to each other. The modem 10base port is connected by cable to fastethernet0/1 and after I entered your commands I did:

router#show interface f0/1

FastEthernet0/1 is up, line protocol is down

Hardware is AmdFE, address is 000c.31ee.67e1 (bia 000c.31ee.67e1)

Description: $ETH-WAN$

Internet address is

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 10Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

what struck me is it shows half duplex and speed 10Mb's like the commands said but then it says 100BaseTX/FX, but my modem is 10base. So do I need to change this and if so what command should I use?

thanks for your further help and await yours.

This widget could not be displayed.