Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Sample config how to terminate pptp at 1720

I have VPN module, WIC-INET on my 1720. Remote clients need to access a W2K server in a private network behind a 1720 router. Does anyone have a working configuration how to terminate a pptp connection at 1720?

Thanks.

JLawan

4 REPLIES
New Member

Re: Sample config how to terminate pptp at 1720

I think this sample config should give you the idea:

http://www.cisco.com/warp/public/116/pptp_3885.html

Hakan

New Member

Re: Sample config how to terminate pptp at 1720

Based on this link, I came up w this config. Remote pptp still could not connect to the 1720. I turned debug all, the call did not hit the 1720 yet. What am I missing in my config? Running IOS v12.2(2)XJ ED. Any help would be appreciated.

JLawan

!

username test password 0 test

memory-size iomem 25

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

!

!

ip name-server 24.x.y.z

!

ip ssh time-out 120

ip ssh authentication-retries 3

ip address-pool local

vpdn enable

vpdn logging

!

vpdn-group PPTP_W2KCLIENT

! Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

!

!

crypto mib ipsec flowmib history tunnel size 200

crypto mib ipsec flowmib history failure size 200

!

!

!

interface Loopback0

ip address 172.16.10.100 255.255.255.0

!

interface Ethernet0

ip address a.b.c.d 255.255.254.0

half-duplex

!

interface FastEthernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

speed auto

!

interface Serial0

ip address 216.x.y.z 255.255.255.252

ip nat outside

no fair-queue

!

interface Virtual-Template1

ip unnumbered Loopback0

peer default ip address pool default

!

ip local pool default 192.168.1.5 192.168.1.10

ip classless

ip route 0.0.0.0 0.0.0.0 a.b.c.1

no ip http server

!

Bronze

Re: Sample config how to terminate pptp at 1720

I do not see any ppp authentication stuff under the Virtual-Interface.

Plus , you would be better off enabling some aaa commands for PPTP user authentication

aaa new

aaa authen ppp def local

If that does not solve the problem, enable the following debugs

debug aaa authen

debug aaa author

debug ppp authen

debug ppp nego

debug VPDN events

debug VPDN errors

New Member

Re: Sample config how to terminate pptp at 1720

Thanks. Got that to work now.

JLawan

117
Views
0
Helpful
4
Replies