Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

SDM configuration

Hi everyone, I'm trying to configure a router for SDM secure connectivity but it's not working. I can see the sdm files when I issued show flash command but it's not working when I try to configure it using " ip http secure-server". Any Idea on how to go about it? Thanks

1 REPLY
New Member

SDM configuration

When you say "sdm files", I think you are meaning the .tar files, correct?

Also, "ip http secure-server" isn't the only thing you need to configre SDM. I'm having a bit of a problem myself. I was able to finally get my SDM to connect to a virtual router in GNS3 environment. However, I now have a 2620XM myself, and SDM won't connect. But, you need to ensure you have aaa new-model running, you need authentication setup for a local user, you need your interfaces properly addressed. I'm going to be posting my own issue with SDM, but here is the config I used:

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
logging monitor informational
!
memory-size iomem 10
no network-clock-participate slot 1
no network-clock-participate wic 0
aaa new-model
!
!
aaa authentication login AAA_LIST_NAME local
aaa session-id common
ip subnet-zero
ip cef
!
username yallaen privilege 15 secret 5 $1$P1rJ$oVvrGIy3m.zjxFspdIP.B1
!
interface Loopback0
ip address 192.168.1.2 255.255.255.0
!
interface FastEthernet0/0
description Network 10.0.0.0/30
ip address 10.0.0.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
description Network 192.168.1.0/24
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 10.0.0.0 0.0.0.3
network 192.168.1.0
auto-summary
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
ip classless
!
!
logging history size 300
logging history informational
logging facility local6
!
!
line con 0
privilege level 15
logging synchronous
login authentication AAA_LIST_NAME
line aux 0
line vty 0 4
privilege level 15
login authentication AAA_LIST_NAME
transport input telnet ssh
line vty 5 15
privilege level 15
login authentication AAA_LIST_NAME
!
!
end

562
Views
0
Helpful
1
Replies