Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Seting up a VPN between 2 x cisco 877

Hi i have 2 Cisco 877 Routers

and iam strungling to set a VPN between these to devices

I have tried using SDM with no joy i need nodes to access remote files and HTTP applications on both sides of the VPN

regards

Dean

1 REPLY
New Member

Re: Seting up a VPN between 2 x cisco 877

hello.

working config

not the changes in the access-list (switching source and destination)

Same for the address components in the crypto sections.

Also, the crypto map my-map should be bound to your external interface (potentially not dialer1)

Tim

!

!

crypto isakmp policy 2

encr 3des

hash md5

authentication pre-share

group 2

crypto isakmp xxx address ip.of.end.B

!

!

crypto ipsec transform-set tf-set esp-3des esp-md5-hmac

!

crypto map my-map 1 ipsec-isakmp

set peer ip.of.end.b

set transform-set tf-set

match address 101

!

!

!

interface Dialer1

crypto map my-map

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 101 permit ip you.subnet.side.a appropriate.mask.for.this your.subnet.side.b appropriate.mask.for.this

!

!

crypto isakmp policy 2

encr 3des

hash md5

authentication pre-share

group 2

crypto isakmp key xxx address ip.of.end.a

!

!

crypto ipsec transform-set tf-set esp-3des esp-md5-hmac

!

crypto map my-map 1 ipsec-isakmp

set peer ip.of.end.a

set transform-set tf-set

match address 101

!

!

!

interface Dialer1

crypto map my-map

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 101 permit ip you.subnet.side.b appropriate.mask.for.this your.subnet.side.a appropriate.mask.for.this

92
Views
0
Helpful
1
Replies