Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

sftp-server doesn't exist

K, after figuring out why my 4230's ssh wouldn't work, I figured it would be a snap to scp the update to the box. Wrong. scp returns "scp: warning: child process (/opt/att/bin/ssh2) exited with code 127." SSH.com has a FAQ about this at http://www.ssh.com/faq/index.cfm?id=677, but I'll get to that.

When I tried to use sftp, much to my chagrin, I found that the sftp-server was not installed! In /etc/sshd_config the path is /usr/libexec, which is where it is on my BSD box (the one I'm recommending instead of this one), but that directory doesn't exist here. Nor does sftp-server exist anywhere else that the find command or my hopeless grepping can see.

Has anyone had this problem and solved it or did they too just give up and spend an hour putting snort on bsd? Sorry if this sounds confrontational, but the point of paying 20 grand as opposed to 2 is so I don't have to personally iron out all the engineering details.

1 REPLY
Cisco Employee

Re: sftp-server doesn't exist

Sorry for the inconvience. This issue was fixed in the 3.1(2) service pack.

141
Views
0
Helpful
1
Replies
CreatePlease login to create content