Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Site to Site VPN w/ Static NAT and route-maps BUT with negotiated public IP

Hi

I've got a client with an 1811 router. We are doing a site to site vpn with another cisco 2801 router. The 1811 router connects to the internet via a dynamic IP address DSL (using a dialer interface, negotiated IP address). Now, I know how to configure a site to site VPN with static nat through the use of route-maps to allow both features to work properly together, however, with this new client and their dynamic public IP address, I cant seem to use the following command;

'ip nat inside source static tcp 192.168.219.1 80 interface dialer 0 81 route-map servernat'

It seems that when I reference an interface as opposed to a static address, it does not allow the route-map extension. Is there any way around this, or any equivalent method of configuring? Or do I have to get a static public IP address for the 1811 site? Thanks very much.

Jason

2 REPLIES
Silver

Re: Site to Site VPN w/ Static NAT and route-maps BUT with negot

New Member

Re: Site to Site VPN w/ Static NAT and route-maps BUT with negot

Hi

Thanks for the reply, but unfortunately that didn't help any...I have no problem creating a VPN tunnel to the dynamic address...the issue is with doing static NAT with route-maps to an interface rather than a specific IP address. This seems to be a problem (feature restriction) on ALL Cisco routers (tried on everything from 1801 through to 7600! with many different code versions). I dont know why there is this restriction as there is no issue doing static NAT to an interface, and static NAT with route maps works fine so long as you specify an actual IP address as the Inside Global...hrmmmm, I wish Cisco would respond to my requests for support on this one, but I seem to be getting ignored. Ah well, such is life. I've gone a head and gotten a static IP address for the site in question and all works fine like that. Cheers. Thanks

jason

142
Views
0
Helpful
2
Replies