Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SNMP not working on PIX

Hi, I have a PIX 515e, version 6.3.3. SNMP doesn't seem to connect from the client to the pix. This client connects to other snmp devices on the network fine, so it must be something on the pix disallowing it.

SNMP config on the pix:

snmp-server host inside 10.21.0.39

snmp-server community public

snmp-server enabled traps

The ip address above is correct for the client I am trying to poll from, and I'm trying to connect to the internal interface of the pix. (Which I can ping/telnet to fine from that ip as well).

Any suggestions on what is going wrong? PDM's monitoring feature doesn't work either, which I assume is based off of SNMP.

-David Graves

2 REPLIES

Re: SNMP not working on PIX

If you have an inside interface access-list then it might be that this access-list blocks SNMP.

Another point is that your SNMP Software might not have the right SNMP MIB with right OIDS to poll your PIX Firewall.

See: Using SNMP with the Cisco Secure PIX Firewall:

http://www.cisco.com/warp/public/110/pixsnmp.html

sincerely

Patrick

New Member

Re: SNMP not working on PIX

I had an inside interface acl, but it had nothing to do with snmp, but I disabled it anyway, and this still occurs. The machine I'm using has ucd-snmp, but even a basic snmpwalk isn't working.

-David

112
Views
0
Helpful
2
Replies
CreatePlease login to create content