Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Troubles installing CW VMS with IDS MC: database server not running

We are installing a new management station for our ids devices for replacing our previous one that is a bit underpowered, but we can't get it up and running to the point of being able to add our sensors. In log files IDS_Analyser, IDS_EvsServer, IDS_Notifier, IDS_ReportScheduler we get errors that the database server is not running. Moreover we have now an extra logging in files smdb_upgrade001.log and smdb_upgrade002.log stating that the database upgrade from version 1.0 to 1.1 was not successful due to another error :

-193 -- Primary key for table 'sys_strings' is not unique

However we thought we were following the right procedure in installing all packages :

- CW CDOne Fifth edition (we installed CiscoView, NMS Integration Utility and CMF)

- Common services (from the CD CW VMS Management & Monitoring V2.2)

- Installation CW VMS for IDS V2.2 by selecting Managing IDS Sensors, Catalyst IDS SM, and Security Monitoring on the same CD

So this should be sufficient to have a working environment and in fact we didn't get any errors at installing all components. Even all services in CW are up and running according to the CW process management.

We are loosing lots of time trying to get this right for once.

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Troubles installing CW VMS with IDS MC: database server not

Johan, It’s a while back since I did the installation but I think the installation of CiscoWorks-VMS-2.2-Update-1-w2k-k9.exe, checks to see what SecMon you have install and will only update it if it is lower than 1.2, after that install SecMon 1.2.3, if you haven’t already done so and then add the patches. I hope that the advice that I have given you here is correct.

5 REPLIES
New Member

Re: Troubles installing CW VMS with IDS MC: database server not

As it seemed, there was a problem with our database. The reason was that we were installing packages too fast (according to the procedure we had made from our previous installed management station). Apparently after installing one version of ids mc, the database needs some 20 minutes to initialize, so we had to wait long enough to apply the upgrades of ids mc towards version 1.2.3. We reinstalled and this problem is gone. However now we have another problem importing the sensors, as the ids mc gives errors on the version of the sensors (4.1(3)S78) that is not recognized by the ids mc. However in the idsmdc.log file there are clear indications that all signature updates/service packs had been applied successfully (from IDS-K9-sp-4.0-2-S42.zip to IDS-sig-4.1-3-S78.zip).

New Member

Re: Troubles installing CW VMS with IDS MC: database server not

Update on our situation : we have re-applied following updates in this order :

- IDS-K9-min-4.1-1-S47.zip

- IDS-K9-sp-4.1-3-S61.zip

- IDS-sig-4.1-3-S78.zip

And now we are able to import the sensors. However we get another error on opening the event viewer in Security Monitor :

'class com.cisco.nm.mdc.ids.monitor.evs.applet.JApplet1 not found.'

This was the error we also got when the database was corrupt.

So now what ? Back to where we were ? This is the installation procedure we followed :

- CW CDOne Fifth edition (we installed CiscoView, NMS Integration Utility and CMF)

- Common services (from the CD CW VMS Management & Monitoring V2.2)

- Installation CW VMS for IDS V2.2 by selecting Managing IDS Sensors, Catalyst IDS SM, and Security Monitoring on the same CD

- Installation SP3 for IDS MC V1.2.

- Installation patches

Is there somewhere a complete installation procedure for installing CW VMS with IDS MC V1.2.3 ? A complete list of all steps to be followed in the right order as to have a successfull installation ?

Best regards,

Johan.

New Member

Re: Troubles installing CW VMS with IDS MC: database server not

I think that you are on the right track, we have all been there.

Make sure that you have installed the following 2 patches on the VMS 2.2 (update 1) server with SecMon 1.2.3

idsmdc1.2.3-win-CSCsa090114.tar

idsmdc1.2.3-win-CSCsa122414.tar

I use to have this problem but it seams to have disappeared since the patches where applied.

I found once I encountered the error, if I closed the event viewer and then reopened it I did not experience the problem again until the next time I was required to open the event viewer. It was ignoring but my problem did not seam to be persistent. By that I mean, if I tied once again to open the event viewer, it usually worked the second time around.

New Member

Re: Troubles installing CW VMS with IDS MC: database server not

Very interesting ! Do we really have to install update 1 ? And if so, can we do directly over our current installation of VMS 2.2 with IDS MC 1.2.3 ?

Thanks,

Johan.

New Member

Re: Troubles installing CW VMS with IDS MC: database server not

Johan, It’s a while back since I did the installation but I think the installation of CiscoWorks-VMS-2.2-Update-1-w2k-k9.exe, checks to see what SecMon you have install and will only update it if it is lower than 1.2, after that install SecMon 1.2.3, if you haven’t already done so and then add the patches. I hope that the advice that I have given you here is correct.

109
Views
3
Helpful
5
Replies
CreatePlease to create content