Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unable to assign ACL to interface device [Cisco] IP [X.X.X.X]

i upgraded my sensor from 2.5(1)S3 to 3.0(1)S4, now i keep getting the following error in error.managed : Unable to assign ACL to interface device [Cisco] IP [X.X.X.X] if [FastEthernet0/0], Connection lost to net device X.X.X.X. I can log into the router and see the access-lists IDS_FastEthernet0/0_in_0 and IDS_FastEthernet0/0_out_0 that it creates, but they never get assigned to an interface. Sorry for posting so much, new to Cisco IDS.

6 REPLIES
Cisco Employee

Re: Unable to assign ACL to interface device [Cisco] IP [X.X.X.X

The sensor got an unexpected response from the router when it tried to assign the ACL.

This will cause the connection to be lost.

Two things you can try....

1. Verify that the router has an interface named FastEthernet0/0. If not, then configure the sensor to use the correct interface name and try running the sensor again.

2. Try these commands in enable mode on the router:

conf term

interface FastEthernet0/0

You should see a prompt like 'config-if' or 'config-subif'

If you do not see one of these prompts, then please post the prompt that you do see.

(At this point, you can type 'exit' twice, since you don't want to

actually configure the device)

If none of these suggestions help, you should open a TAC case. A TAC engineer will ask you

for your configuration info, and I will investigate further (stleary@cisco.com)

New Member

Re: Unable to assign ACL to interface device [Cisco] IP [X.X.X.X

the prompt stays as a "conf" this is probably because the hostname of the router is long.

Cisco Employee

Re: Unable to assign ACL to interface device [Cisco] IP [X.X.X.X

The hostname should be less than 18 chars in length.

I will write up a bug report, but the resolution will probably just be that we will update the user guide with a note.

New Member

Re: Unable to assign ACL to interface device [Cisco] IP [X.X.X.X

sure...This is the hostname: hiss1_t3_sprint_7206vxr# This is the prompt in config mode: hiss1_t3_sprint_7206vxr(conf)# And this is the prompt in interface config mode for FastEthernet0/0: hiss1_t3_sprint_7206vxr(conf)#

Let me try to shorten the name and see if that helps.

Cisco Employee

Re: Unable to assign ACL to interface device [Cisco] IP [X.X.X.X

OK Thanks. See my earlier post, which I just edited. We will continue investigating on this side, but a shorter name should fix the problem.

New Member

Re: Unable to assign ACL to interface device [Cisco] IP [X.X.X.X

you are right on the money. shortened the name and it applied it fine. you are the man. thanks for all your help, i appreciate it.

166
Views
0
Helpful
6
Replies