Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unable to run ASDM

Hi all,

I am unable to run ASDM and it's drving me potty.

The ASA is running 802-K8.bin and has ASDM-602.bin.

I have tried all of the obvious stuff - Latest version of Java, clearing the cache, different browser

(same problem with Firefox or IE,) reinstalling ASDM, removing all traces of it from the registry and reinstalling.

Everytime I run the app it hangs whilst loading and the Java console reports this:

Java Web Start 1.6.0_21
Using JRE version 1.6.0_21-b06 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\JasonM
----------------------------------------------------

----------------------------------------------------
Application Logging Started at Thu Jul 29 12:35:38 BST 2010
---------------------------------------------
Local Launcher Version = 1.5.46
Local Launcher Version Display = 1.5(46)
OK button clicked
Trying for ASDM Version file; url = https://10.201.255.251/admin/
Server Version = 6.2(5)
Server Launcher Version = 1.5.46, size = 450048 bytes
invoking SGZ Loader..
Cache location = C:/Documents and Settings/JasonM/.asdm/cache
Exception in thread "SGZ Loader: launchSgzApplet" java.lang.NoSuchMethodError: ec.a()V


    at a42.a(a42.java:37)
    at a4v.<clinit>(a4v.java:70)
    at oe.a(oe.java:287)
    at oe.<init>(oe.java:259)
    at com.cisco.pdm.PDMApplet.start(PDMApplet.java:160)
    at com.cisco.nm.dice.loader.r.run(DashoA19*..:410)

If anyone knows what this means and how to fix it, I'd be really grateful.

Thank you,

Jason Mendonca

3 REPLIES
Cisco Employee

Re: Unable to run ASDM

This could be one of the old ASDM bugs.

Can you load ASDM 6.2.5, the latest image and see if it works?

PK

New Member

Re: Unable to run ASDM

Hi Jason,

I'm having exactly the same problem.

Did the last version of ADSM solve the problem ?

Regards,

Carlos Miranda

New Member

Re: Unable to run ASDM

Hi Carlos,

Unfortunately, I don't have access to that version of code so I am unable test this.

I know it's a Windows / Java related issue though as I am unable to run ASDM from my colleagues laptop without issue.

It's getting embarrasing though, as I turn up to customers sites and am unable to use ASDM to fix their firewall issues.

My command line skills are rapidly improving though

695
Views
0
Helpful
3
Replies