Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Upgrade to 2.2.2a and 3.0 <from a sensor 2.2.0>

I recently took over the IDS systems at a client... their sigs and bases were 2.2.0 on some sensors,2.5 on others.

I upgraded the Unx Director to 2.2.2a w/ S3 sigs and One sensor from 2.2.0-->2.5<CD>-->3.0

I had two new sensors with 2.5 and upgraded them to 3.0.

I still have one more sensor thats 2.2.0 but with all custom sigs and filters...

My issue is that the Director can configure the 2.5-->3.0 sensors fine. But when it tries to open the 2.2.0-->2.5-->3.0 sensor, it does so only after displaying an error:

"unable to download the following files from 'sensorX' etc/smid.conf please ensure that your communication infrastructure between local and remote machine is functioning properly"

nrConns shows all communications established.

idsvers shows on the sensor all "v175"

I deleted and readded the sensor<as new> on the director but still get the same error. The config screen opens next and changes can be made however applying the changes never seems to occur and i eventually have to kill the ovw process on the director.

Other than the config piece, everything else went fine.

Is there something I missed or can check in regards to the etc/smid.conf error message?

many thanks

2 REPLIES
Cisco Employee

Re: Upgrade to 2.2.2a and 3.0 <from a sensor 2.2.0>

There are known issues when upgrading from 2.2.0 or 2.2.1 to 2.5 or 3.0.

The confugurations from the 2 versions are not compatible.

You will need to do the following:

1) Open the nrConfigure tool

2) Delete the entry for the current sensor

3) Run sysconfig-sensor Option 6 to create new configuration files on the sensor.

3) Select the Add Host wizard option and add the sensor as a New

sensor.

4) Redo any customizations for the sensor.

The DDTS Issue is: CSCdu10952

The Release Notes have other workarounds but because of the drastic upgrade in versions these other workarounds would be difficult to implement.

New Member

Re: Upgrade to 2.2.2a and 3.0 <from a sensor 2.2.0>

Thanks, Actually I did delete and readd it a second time(as a new sensor) and it worked fine. I suspect I either mistyped the naming of the sensor( _ not - ) when I first readded it OR I didn't actually add it as a new sensor...

As a followup test, I did my other 2.2.0 sensor today:

Going from 2.2.0-->2.5CD-->3.0 and then on the director's nrConfigure Tool, I deleted it and readded it as a new sensor.

..No problems whatsoever!

112
Views
0
Helpful
2
Replies
CreatePlease login to create content