Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VPN client unable to connect to the PIX firewall

The below config VPN config was one of the simulation I found on the Cisco web.If I'm using Windows PPTP connection all is working fine and I was able to authenticate and get the local IP address but if I'm using Cisco VPN 3.6.3 to connect the authentication will took some time and at the end it says remote peer is not responding.On my PIX monitoring console I can view the connection.Any advise.

:

PIX Version 6.2(2)

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

hostname ciscopix

domain-name cisco.com

fixup protocol ftp 21

fixup protocol http 80

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol sip 5060

fixup protocol skinny 2000

names

access-list 101 permit ip 10.0.0.0 255.255.255.0 192.168.1.0 255.255.255.0

access-list 101 permit ip any 192.168.1.0 255.255.255.0

access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.0 255.255.255.0

interface ethernet1 auto

mtu outside 1500

mtu inside 1500

ip address outside 172.18.124.152 255.255.255.0

ip address inside 10.99.99.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool abc 192.168.1.1-192.168.1.254

pdm location 10.99.99.156 255.255.255.255 inside

pdm location 192.168.1.0 255.255.255.0 outside

pdm location 10.0.0.0 255.255.255.0 inside

pdm history enable

arp timeout 14400

nat (inside) 0 access-list 101

nat (inside) 0 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 172.18.124.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si

p 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

http server enable

http 10.99.99.156 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

sysopt connection permit-pptp

no sysopt route dnat

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20

crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-MD5

crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map

crypto map outside_map client authentication RADIUS

crypto map outside_map interface outside

isakmp enable outside

isakmp enable inside

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption des

isakmp policy 20 hash md5

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

vpngroup abc idle-time 1800

vpngroup abc password ********

telnet timeout 5

ssh timeout 5

vpdn group PPTP-VPDN-GROUP accept dialin pptp

vpdn group PPTP-VPDN-GROUP ppp authentication pap

vpdn group PPTP-VPDN-GROUP ppp authentication chap

vpdn group PPTP-VPDN-GROUP ppp authentication mschap

vpdn group PPTP-VPDN-GROUP ppp encryption mppe 40

vpdn group PPTP-VPDN-GROUP client configuration address local abc

vpdn group PPTP-VPDN-GROUP pptp echo 60

vpdn group PPTP-VPDN-GROUP client authentication local

vpdn username Cisco password *********

vpdn enable outside

vpdn enable inside

vpnclient vpngroup abc password ********

vpnclient username abc password ********

vpnclient server 10.99.99.1

vpnclient mode client-mode

terminal width 80

Cryptochecksum:2253ea1de97c2d82c62593eb433ad813

: end

2 REPLIES
Cisco Employee

Re: VPN client unable to connect to the PIX firewall

The "vpdn" commands configure your PPTP access, which is working fine as you mentioned. You might want to take off the "vpdn enable inside" command, unless you have PPTP users on your inside interface connecting to this PIX it is not necessary.

The "vpnclient" commands, which I presume are what you've configured for the v3.6.3 client to connect, is wrong. The "vpnclient" command enables the EzVPN client configuration in teh PIX, meaning the PIX will simulate a VPN client and establish a session to another PIX/router or VPN3000 concentrator. It is NOT used to enable remote VPN clients to connect into this PIX, which is why you're getting "remote peer not responding".

Remove the "vpnclient " commands and use the "vpngroup" commands to configure the PIX to accept VPN client connections. A sample config is here:

http://www.cisco.com/warp/public/110/pix3000.html

New Member

Re: VPN client unable to connect to the PIX firewall

Hi buddy,thks for your respond any I try it out your method, by removing the VPN client and left the vpngroup only but it still the same.

After I put in the group name and group password the authenticating will happen and it will take very long and at the end it will display 'remote peer is no longer responding'.And as usual the PPTP will able to connect.

Any advise.

:

PIX Version 6.2(2)

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

hostname ciscopix

domain-name cisco.com

fixup protocol ftp 21

fixup protocol http 80

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol sip 5060

fixup protocol skinny 2000

names

access-list 101 permit ip 10.0.0.0 255.255.255.0 192.168.1.0 255.255.255.0

access-list 101 permit ip any 192.168.1.0 255.255.255.0

access-list 100 permit tcp any host 172.18.124.160 eq www

pager lines 24

interface ethernet0 auto

interface ethernet1 auto

mtu outside 1500

mtu inside 1500

ip address outside 172.18.124.152 255.255.255.0

ip address inside 10.99.99.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool abc 192.168.1.1-192.168.1.254

pdm location 10.99.99.156 255.255.255.255 inside

pdm location 192.168.1.0 255.255.255.0 outside

pdm location 10.0.0.0 255.255.255.0 inside

pdm history enable

arp timeout 14400

nat (inside) 0 access-list 101

nat (inside) 0 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 172.18.124.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si

p 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server LOCAL protocol local

aaa authorization command LOCAL

http server enable

http 10.99.99.156 255.255.255.255 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

sysopt connection permit-pptp

no sysopt route dnat

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto dynamic-map outside_dyn_map 20 set transform-set ESP-DES-MD5

crypto dynamic-map outside_dyn_map 40 set transform-set ESP-DES-MD5

crypto dynamic-map outside_dyn_map 60 match address outside_cryptomap_dyn_60

crypto dynamic-map outside_dyn_map 60 set transform-set ESP-DES-MD5

crypto dynamic-map outside_dyn_map 80 match address outside_cryptomap_dyn_80

crypto dynamic-map outside_dyn_map 80 set transform-set ESP-DES-MD5

crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map

crypto map outside_map client configuration address initiate

crypto map outside_map client configuration address respond

crypto map outside_map client authentication RADIUS

isakmp enable outside

isakmp enable inside

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption des

isakmp policy 20 hash md5

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

vpngroup abc address-pool abc

vpngroup abc idle-time 1800

vpngroup abc password ********

telnet timeout 5

ssh timeout 5

vpdn group PPTP-VPDN-GROUP accept dialin pptp

vpdn group PPTP-VPDN-GROUP ppp authentication pap

vpdn group PPTP-VPDN-GROUP ppp authentication chap

vpdn group PPTP-VPDN-GROUP ppp authentication mschap

vpdn group PPTP-VPDN-GROUP ppp encryption mppe 40

vpdn group PPTP-VPDN-GROUP client configuration address local abc

vpdn group PPTP-VPDN-GROUP pptp echo 60

vpdn group PPTP-VPDN-GROUP client authentication local

vpdn username test password *********

vpdn enable outside

terminal width 80

127
Views
0
Helpful
2
Replies
CreatePlease login to create content