Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

VPN connection works, but cant access inside network.

I have a pix501 on the edge of a remote site. I have a vpn tunnel connection, however I cant seem to access anything on the inside.

I have my config shown below-

AKCPIX00(config)# sh run

: Saved

:

PIX Version 6.2(3)

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxxxxxx encrypted

passwd xxxxxencrypted

hostname Pixydust

fixup protocol ftp 21

fixup protocol http 80

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol sip 5060

fixup protocol skinny 2000

fixup protocol sip udp 5060

names

pager lines 24

interface ethernet0 10baset

interface ethernet1 10full

mtu outside 1500

mtu inside 1500

ip address outside (ip address) 255.255.240.0

ip address inside 192.168.1.5 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

route outside 0.0.0.0 0.0.0.0 (ip address) 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server RADIUS protocol radius

aaa-server LOCAL protocol local

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

no sysopt route dnat

telnet timeout 5

ssh timeout 5

dhcpd address 192.168.1.100-192.168.1.130 inside

dhcpd dns 192.168.1.10

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd enable inside

terminal width 80

ip local pool akcpool 10.0.0.1-10.0.0.10

access-list 101 permit ip 192.168.1.0 255.255.255.0 10.0.0.0 255.255.255.0

nat (inside) 0 access-list 101

sysopt connection permit-ipsec

crypto ipsec transform-set akcset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set akcset

crypto map akcmap 10 ipsec-isakmp dynamic dynmap

crypto map akcmap client configuration address initiate

crypto map akcmap client configuration address respond

crypto map akcmap interface outside

isakmp enable outside

isakmp key ******* address 0.0.0.0 netmask 0.0.0.0

isakmp identity address

isakmp client configuration address-pool local akcpool outside

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption des

isakmp policy 20 hash md5

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

vpngroup akcgroup address-pool akcpool

vpngroup akcgroup dns-server 192.168.1.10

vpngroup akcgroup default-domain password

vpngroup akcgroup idle-time 1800

vpngroup akcgroup password *******

Cryptochecksum:xxxx

: end

Thanks

3 REPLIES
New Member

Re: VPN connection works, but cant access inside network.

Your configuration does not show any access list, please check your access list for any specific deny statements.

New Member

Re: VPN connection works, but cant access inside network.

You might look into enabling NAT traversal, it doesn't look like you have it enabled.

You can do this through the PDM under configuration/vpn/policies. or in the command line with syntax as follows: isakmp nat-traversal 20.

Good Luck.

New Member

Re: VPN connection works, but cant access inside network.

Hi,

I had the same issue and follow your suggestion and put the nat-traversal 20 line and it works.

Can you tell me what that command does?

Thank you much.

Uriel Naranjo

94
Views
0
Helpful
3
Replies
CreatePlease to create content