Cisco Support Community
Community Member

VPN problems

My vpn is saying that it is connected, but when I try to map a network drive or even try to go to the internet I can't. Also the only device that I can ping are is the subnet that was dynamiclly asigned via pix firewall. Everything on my local lan is blocked until I disconnect the vpn. This is the config of the PIX that I am trying to vpn into.

PIX Version 6.3(5)

interface ethernet0 auto

interface ethernet1 auto

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxx encrypted

passwd xxxx

hostname pixfirewall


fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol smtp 1025

fixup protocol sqlnet 1521

fixup protocol tftp 69


access-list outside_access_in permit tcp any interface outside eq 3389

access-list outside_access_in permit icmp any any

access-list inside_outbound_nat0_acl permit ip any

access-list outside_cryptomap_dyn_20 permit ip any

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside dhcp setroute retry 4

ip address inside

ip audit info action alarm

ip audit attack action alarm

ip local pool familyabuse

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_outbound_nat0_acl

nat (inside) 1 0 0

static (inside,outside) tcp interface 3389 3389 netmask 255.255.255

.255 0 0

access-group outside_access_in in interface outside

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20

crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5

crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map

crypto map outside_map interface outside

isakmp enable outside

isakmp policy 20 authentication pre-share

isakmp policy 20 encryption 3des

isakmp policy 20 hash md5

isakmp policy 20 group 2

isakmp policy 20 lifetime 86400

vpngroup familyabuse address-pool familyabuse

vpngroup familyabuse dns-server

vpngroup familyabuse wins-server

vpngroup familyabuse default-domain

vpngroup familyabuse idle-time 1800

vpngroup familyabuse password ********

telnet inside

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address inside

dhcpd dns

dhcpd wins

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd domain

dhcpd auto_config outside

dhcpd enable inside

terminal width 80


: end

Community Member

Re: VPN problems

This is default behavior of VPN. When you connect from VPN client, you will be a part of the VPN server allocated LAN network. Later on there will be no significance of local IP, that’s why your share drive and internet not works.

To overcome this issue you can unable SPLIT TUNNELING concept on VPN server i.e.PIX., But its supported on PIX 7.X or VPN Concetrators.

Community Member

Re: VPN problems

I think you mean you have to define a split tunnel and this is a supported set of commands for version 6 as well.

These are the lines you would need to add (especially if you don't want to use over your outside_crypto ACL):

access-list Tunnel permit ip any

vpngroup familyabuse split-tunnel Tunnel

(I usually don't use an outside_crypto_dyn ACL but I believe the PDM likes this, if that is what you've used instead of CLI.)

Two last questions:

Why are you using any in your access-lists instead of defining the internal network?

Also, why don't you define an entirely different scheme for your vpn groups, e.g. so as not to cause confusion and be able to define the networks in the ACLs clearly?

Just some suggestions :-)

Good luck,


Re: VPN problems

I yust would like to confirm the Post of Nicole.

Yes split tunnel solvs the limitation.

Yes PIX OS 6.x supports Split tunnel.

But it would be a better security pratcise to use a Proxy Server for the VPN users to access the Internet when the users are connected to the VPN.

If a host (VPN client) gets hijacked on the Internet the Intruder will be able to enter into your corporate network. Which is not the case when you use a Proxy server.

Free proxys = Squid (Linux) or Symantec (With Enterprise Ed.)



CreatePlease to create content