Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VPN tunnels

Please can someone help with a VPN question. When I create a tunnel interface and bind it to an ethernet interface, can the ethernet interface only be used for the tunnel only or can VPN traffic be routed to the tunnel and normal traffice passed straight thru.

Regards

Bryan

5 REPLIES
New Member

Re: VPN tunnels

Hi Bryan,

you can use the ethernet interface for both.

You habe to make your routing entries for the Ethernet and for the tunnel.

- Carsten

New Member

Re: VPN tunnels

Excellent, thanks for the information. Are you able to point me to Cisco's website for any examples of this as this would be most appreciated.

New Member

Re: VPN tunnels

Sorry I've no side but a sample config for you.

I hope it would be helpfull.

interface Tunnel2

description tunnel to ...

ip unnumbered Ethernet1/0

no ip directed-broadcast

tunnel source xxx.xxx.32.141

tunnel destination xxx.xxx.203.133

tunnel sequence-datagrams

!

interface Serial0/0:1

description ....

ip address xx.xxx.32.141 255.255.255.252

no ip directed-broadcast

ip accounting output-packets

ip mroute-cache

!

ip route xxx.xxx.35.0 255.255.255.0 Tunnel1

- Carsten

New Member

Re: VPN tunnels

I have some actual working models.

!

interface Tunnel94

ip address 172.94.0.2 255.255.255.252

tunnel source Ethernet0/0

tunnel destination xx.xx.147.138

tunnel mode ipip

!

interface Tunnel95

ip address 172.95.0.2 255.255.255.252

tunnel source Ethernet0/0

tunnel destination xx.xx.205.250

tunnel mode ipip

!

interface Tunnel195

ip address 172.195.0.2 255.255.255.252

delay 3000

tunnel source Ethernet0/0

tunnel destination xx.xx.92.151

!

interface Ethernet0/0

description Exodus LAN

ip address 10.11.1.1 255.255.0.0

!

interface Serial0/0

description P2P T1

ip address 10.20.1.2 255.255.255.252

service-module t1 clock source internal

!

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.11.1.10

ip route 10.94.0.0 255.255.255.0 Tunnel94

ip route 10.95.0.0 255.255.255.0 Tunnel95

ip route 10.195.0.0 255.255.255.0 Tunnel195

New Member

Re: VPN tunnels

Hi, I was also need to VPN to a remote site while maintaining internet access for the local network. Great example by the way!

Let me see if I am correct in this hack of your example.

I want to tunnel internal LAN 192.168.1.1.

To remote IP xxx.225.137.113.

From here xxx.11.70.9

My config:

interface Tunnel70

ip address xx.11.70.9 255.255.255.248

tunnel source Ethernet0/0

tunnel destination 66.225.137.113

tunnel mode ipip

!

!

interface Ethernet0/0

description Exodus LAN

ip address 192.168.1.1 255.255.255.0

!

interface Serial0/0

description P2P E10

ip address xxx.11.70.9 255.255.255.248

service-module t1 clock source internal

!

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route xxx.225.137.113 255.255.255.0 Tunnel70

TIA for any pointers...

George

101
Views
0
Helpful
5
Replies