Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

vpning in and then asdm or ssh

ciscoasa# sh run

: Saved

:

ASA Version 8.0(2)

!

hostname ciscoasa

enable password xxx

names

!

interface Ethernet0/0

nameif outside

security-level 0

ip address internet_ip 255.255.255.224

!

interface Ethernet0/1

nameif inside

security-level 100

ip address 172.17.193.1 255.255.255.0

!

interface Ethernet0/2

shutdown

no nameif

no security-level

no ip address

!

interface Ethernet0/3

shutdown

no nameif

no security-level

no ip address

!

interface Management0/0

nameif management

security-level 100

ip address 192.168.1.1 255.255.255.0

management-only

!

passwd xxx

ftp mode passive

clock timezone mst -7

access-list split_tunnel_list standard permit 172.17.193.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 172.17.193.0 255.255.255.0 192.168.10.0 255.255.255.0

access-list outside_access_in extended permit tcp any host internet_ip eq www

pager lines 24

logging enable

logging asdm informational

mtu outside 1500

mtu inside 1500

mtu management 1500

ip local pool vpnuserspool 192.168.10.101-192.168.10.254 mask 255.255.255.0

no failover

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-602.bin

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 172.17.193.0 255.255.255.0

static (inside,outside) tcp interface www 172.17.193.101 www netmask 255.255.255.255

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 isp_gateway 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

aaa authentication ssh console LOCAL

http server enable

http internet_ip_2 255.255.255.255 outside

http 192.168.1.0 255.255.255.0 management

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

no crypto isakmp nat-traversal

telnet timeout 5

ssh scopy enable

ssh internet_ip_2 255.255.255.255 outside

ssh timeout 60

console timeout 0

dhcpd address 172.17.193.101-172.17.193.254 inside

dhcpd dns dns_1 dns_2 interface inside

dhcpd enable inside

!

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd enable management

!

threat-detection basic-threat

threat-detection statistics access-list

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

message-length maximum 512

policy-map global_policy

class inspection_default

inspect dns preset_dns_map

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect esmtp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp

!

service-policy global_policy global

webvpn

enable outside

svc image disk0:/anyconnect-win-2.2.0133-k9.pkg 1

svc enable

group-policy vpnuserspolicy internal

group-policy vpnuserspolicy attributes

vpn-tunnel-protocol svc webvpn

split-tunnel-policy tunnelspecified

split-tunnel-network-list value split_tunnel_list

address-pools value vpnuserspool

username admin password xxx encrypted privilege 15

username vpnuser1 password xxx encrypted

username vpnuser1 attributes

vpn-group-policy vpnuserspolicy

prompt hostname context

Cryptochecksum:xxx

: end

3 REPLIES
Community Member

Re: vpning in and then asdm or ssh

VPN works. What I want to do is vpning into the device as admin, and then load up ssh or asdm and connect to the device (presumably 172.17.193.1 since that's the inside interface).

I tried:

ssh 192.168.10.0 255.255.255.0 outside

http 192.168.10.0 255.255.255.0 outside

but it doesn't work.

Community Member

Re: vpning in and then asdm or ssh

The best way to do this is to just have a single internal host that can access the SSH/ASDM. Allow RDP(Windows Box) or SSH (*nix box) access to it. This does not give blanket access to a huge range of IP's, much more secure.

But if you do wish to do it the other way, you are going to have to add and entry to your ACL:

access-list outside_access_in extended permit tcp 192.168.10.0 255.255.255.0 host 172.17.193.1 eq ssh and https

or

access-list outside_access_in extended permit ip 192.168.10.0 255.255.255.0 host 172.17.193.0 255.255.255.0

You will also need a nat exempt for source 192.168.10.0 destination 172.17.193.0

hope this helps.

Community Member

Re: vpning in and then asdm or ssh

I did this:

access-list outside_access_in extended permit ip 192.168.10.0 255.255.255.0 host 172.17.193.1

access-group outside_access_in in interface outside

ssh 192.168.10.0 255.255.255.0 inside

nat (outside) 0 access-list outside_access_in

ssh didn't work. Getting

3 Jun 25 2008 15:46:23 710003 192.168.10.101 172.17.193.1 TCP access denied by ACL from 192.168.10.101/1269 to outside:172.17.193.1/22

138
Views
0
Helpful
3
Replies
CreatePlease to create content