Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

integrate third party xmpp client with cisco unified presence server failing SSL handshaking

We have CUCM 10.0 and cisco unfied presence services 10.0 installed in inhouse lab. Currently we are implementing a xmpp web client using Matrix XMPP API to integrate with CUPS over BOSH. The client keeps failing on SSL authentication with cisco XCP web connection manager:

08:31:01.572 |f51fbb70| info| TCPSocketStream::_doSSLHandshake Failure performing SSL handshake: 5

we have 2 xmpp domain configured: cucm10.local and cucmexample.local. I have cup-xmpp.pem downloaded and installed on client PC. Still no go. The application return error is:

The remote certificate is invalid according to the validation procedure.

I suspect the client certificate I uploaded to CUPS is invalid.

I tried to upload the client certificate to CUPS as cup-xmpp-trust via CUPS OS administration as suggested in the documentation but it is always removed by CUPS shortly after being uploaded successfully. So what kind of client certificate is required and how do I generate it?

Thx

 

  • Other Service Provider Subjects
Everyone's tags (1)
383
Views
0
Helpful
0
Replies
This widget could not be displayed.