Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IOS image couldn't be copied to any file system

Hi All,

 

I'm having issues dowloading an IOS from FTP server. Connectivity was already checked and verified.

See error below;

switch#copy tftp bootflash:
Address or name of remote host []? 146.10.67.69
Source filename []? out/cat4500e-entservicesk9-mz.122-53.SG4.bin
Destination filename [cat4500e-entservicesk9-mz.122-53.SG4.bin]?
Accessing tftp://146.10.67.69/cat4500e-entservicesk9-mz.122-53.SG4.bin...
%Error opening tftp://146.170.67.68/cat4500e-entservicesk9-mz.122-53.SG4.bin (No such device)

When I tried to save a text file to the bootflash, it won't save.

switch#copy run bootflash:config.txt
Destination filename [config.txt]?
%Error opening system:/running-config (No such device)
switch#

I can write on the nvram

switch#wr
Building configuration...
Compressed configuration from 39462 bytes to 13833 bytes[OK]
switch#

Can we concluded that my bootflash is corrupted?

 

Cheers,

Sheila

 

 

Everyone's tags (4)
2 REPLIES
Hall of Fame Super Gold

Post the output to the

Post the output to the following commands: 

 

1.  sh version; 

2.  sh bootvar; and 

3.  dir sup-bootflash:

New Member

 Hi Leo,See details below

 

Hi Leo,

See details below;

switch#sh ver
Cisco IOS Software, Catalyst 4000 L3 Switch Software (cat4000-I5S-M), Version 12.2(25)EWA10, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 11-Jul-07 00:44 by dchih
Image text-base: 0x10000000, data-base: 0x114BC038

ROM: 12.2(31r)SG3
Dagobah Revision 226, Swamp Revision 32

switch uptime is 20 weeks, 5 days, 7 hours, 56 minutes
System returned to ROM by power-on
System restarted at 19:36:50 GMT Sat Oct 19 2013
System image file is "bootflash:cat4000-i5s-mz.122-25.EWA10.bin"

cisco WS-C4506 (MPC8245) processor (revision 14) with 524288K bytes of memory.
Processor board ID XXXXXXXX
MPC8245 CPU at 333Mhz, Supervisor IV
Last reset from PowerUp
24 Virtual Ethernet interfaces
48 FastEthernet interfaces
32 Gigabit Ethernet interfaces
403K bytes of non-volatile configuration memory.

Configuration register is 0x2101 (will be 0x2102 at next reload)

switch#sh bootvar
BOOT variable =
CONFIG_FILE variable does not exist
BOOTLDR variable does not exist
Configuration register is 0x2101 (will be 0x2102 at next reload)

switch#dir sup-boot
switch#dir sup-bootflash:
                             ^
% Invalid input detected at '^' marker.

switch#dir
Directory of bootflash:/

    1  -rwx    12402868  Oct 27 2007 14:44:02 +00:00  cat4000-i5s-mz.122-25.EWA10.bin
    2  -rwx    12403328   Oct 2 2008 02:34:24 +00:00  cat4000-i5s-mz.122-25.EWA12.bin

61341696 bytes total (36535244 bytes free)
switch#dir sup-bootflash
%Error opening bootflash:/sup-bootflash (File not found)
switch#
switch#

 

Also to add, we have a flash on Slot0: and having the same issue. I have tried to reformat it then copy the IOS again but still no luck.

switch#sh file system
File Systems:

     Size(b)     Free(b)      Type  Flags  Prefixes
*   61341696    36535244     flash     rw   bootflash:
    63897600    63897600     flash     rw   slot0:
           -           -    opaque     rw   system:
           -           -    opaque     ro   crashinfo:
      524284      522948     flash     rw   cat4000_flash:
      413676      394189     nvram     rw   nvram:
           -           -    opaque     rw   null:
           -           -    opaque     ro   profiler:
           -           -   network     rw   tftp:
           -           -   network     rw   rcp:
           -           -   network     rw   http:
           -           -   network     rw   ftp:
           -           -    opaque     ro   cns:

 

switch#format slot0:
Format operation may take a while. Continue? [confirm]
Format operation will destroy all data in "slot0:".  Continue? [confirm]
Enter volume ID (up to 64 chars)[default slot0]:
                      
Format of slot0 complete
switch#

 

switch#copy ftp slot0:
Address or name of remote host []? 146.170.67.68
Source filename []? out/cat4500e-entservicesk9-mz.122-53.SG4.bin
Destination filename [cat4500e-entservicesk9-mz.122-53.SG4.bin]?
Accessing ftp://146.170.67.68/out/cat4500e-entservicesk9-mz.122-53.SG4.bin...
%Error opening ftp://146.170.67.68/out/cat4500e-entservicesk9-mz.122-53.SG4.bin (No such device)
switch#

 

471
Views
0
Helpful
2
Replies
CreatePlease login to create content