Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

MWR2941 routed ports

We have cisco mwr 2941 with last software version.And we want to give IP addreses to gigabit ports. But when we do it, we see this:

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#int g0/1

Router(config-if)#no sw

Command rejected: Not a convertible port.

Router(config-if)#ip add

Router(config-if)#ip add?

But in this config guide I saw that IP address can be assigned to built-in gigabit ports.

http://www.cisco.com/en/US/docs/wireless/mwr_2941_dc/software_config/guide/appB1.html

Is it hardware limitation, or software bug? We tried to use other software version, bun result was the same.

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: MWR2941 routed ports

Vladimir-

The documentation for the 2941 is horribly innaccurate. You cannot assign an IP address directly to the gigabit interfaces -- you must configure an SVI and give it an addres instead. Here is an example:

interface GigabitEthernet0/0

description link to Core

switchport access vlan 100

switchport mode access

interface Vlan100

description Backhaul

ip address 10.10.5.2 255.255.255.252

no ptp enable

mpls ip

Let me know if this helps. I recently worked on a fairly large project deploying 2941's for CESoPSN pseudowire backhaul of TDM CDMA sites over IP. I may be able to help out more if you have any other questions.  By the way - make sure you are using the absolute latest v15 IOS or you will have all sorts of problems.

Paul

2 REPLIES
New Member

Re: MWR2941 routed ports

Vladimir-

The documentation for the 2941 is horribly innaccurate. You cannot assign an IP address directly to the gigabit interfaces -- you must configure an SVI and give it an addres instead. Here is an example:

interface GigabitEthernet0/0

description link to Core

switchport access vlan 100

switchport mode access

interface Vlan100

description Backhaul

ip address 10.10.5.2 255.255.255.252

no ptp enable

mpls ip

Let me know if this helps. I recently worked on a fairly large project deploying 2941's for CESoPSN pseudowire backhaul of TDM CDMA sites over IP. I may be able to help out more if you have any other questions.  By the way - make sure you are using the absolute latest v15 IOS or you will have all sorts of problems.

Paul

Re: MWR2941 routed ports

pstebner10, thanks for the help, it works.

451
Views
0
Helpful
2
Replies
CreatePlease to create content