Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

per session QoS for LNS

We have some LNSs running 12.4 SP Services, running with the following config (qos specific lines and currently not working):

!

class-map match-all voice-signaling

match access-group 101

class-map match-all voice-traffic

match access-group 102

!

!

policy-map sub-policy

class voice-traffic

priority 240

class voice-signaling

bandwidth 16

policy-map XXX_qos-voice

class class-default

shape average 256000

fair-queue

service-policy sub-policy

!

interface Virtual-Template1

ip unnumbered Loopback0

ip mroute-cache

no peer default ip address

ppp authentication chap

no clns route-cache

!

access-list 101 remark -- SCCP/H323/MGCP/SIP --

access-list 101 permit tcp any any range 2000 2002

access-list 101 permit tcp any any eq 1720

access-list 101 permit tcp any any range 11000 11999

access-list 101 permit udp any any eq 2427

access-list 101 permit udp any any eq 4569

access-list 101 permit udp any any eq 5036

access-list 101 permit udp any any eq 5060

access-list 102 remark -- RTP Traffic --

access-list 102 permit udp any any range 16384 32767

in the feature set for the IOS currently running it suggests this configuration should work, however it will not apply the policy via the Cisco-AVPair command (the command is visible via the debug AAA per user so radius is working, even when we test it by applying the service-policy to the actual virtual-template it errors saying it will only work on an MPL bundle. From what I have read it is suggested that even though this feature is supposed to work, it does not in practice and an upgrade to a feature set which includes QoS:per session shaping and queueing on LNS is needed.

If anyone has any experience of the or has any suggestion of if we can achieve our QoS for voice per session with the current IOS that would be great.

3 REPLIES
Cisco Employee

Re: per session QoS for LNS

Hi Per session shaping on LNS is only supported in 12.2SB train starting with 12.2(28)SB

HTH

Laurent.

New Member

Re: per session QoS for LNS

Thanks for that, am I correct in thinking I have to upgrade our NPE-400's to NPE-1G minimum for 12.2SB? or do they need to be NPE-2G?

Thanks

Cisco Employee

Re: per session QoS for LNS

This feature is not related to the NPE type. This feature is performance impacting so you should do some tests to see if your NPE-400 can support the number of L2TP tunnels you want with this feature enabled. If it's not the case, you will have to upgrade your NPE.

HTH

Laurent.

330
Views
5
Helpful
3
Replies