Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Trouble with ROM and Fabric downloader upgrades

  So I'm new to the 12K series for linecard firmwares.  I've been tasked to upgrade all the ROMs and such in prep for migration from IOS to IOS-XR.

The requirements are:

Line cards (LCs)

For Engine 3 line card:

Maintenance Bus (MBUS) Agent Software-RAM version 04.06, ROM version 04.06

ROM Monitor version 17.1

Fabric Downloader - RAM version 8.0, ROM version 8.0 (The ROM version will be the same as the RAM version if upgraded.)

Route processors (RPs)

For Performance Route Processor 2 (PRP-2):

–Maintenance Bus (MBUS) Agent Software-RAM version 04.06, ROM version 04.06

ROM Monitor version 1.24

I am currently at:

rotgsr-2#show diags | include SLOT | ROM Monitor      

SLOT 4  (RP/LC 4 ): Performance Route Processor

  ROM Monitor version 1.24

SLOT 5  (RP/LC 5 ): 4 Port ISE Gigabit Ethernet

  ROM Monitor version 19.1

rotgsr-2#show diags | inc SLOT| MBUS | Fabric Downloader
SLOT 4  (RP/LC 4 ): Performance Route Processor
  MBUS: MBUS Agent (1)  73-8048-07 rev A0 dev 0
  MBUS Agent Software version 2.72 (RAM) (ROM version is 3.69)
SLOT 5  (RP/LC 5 ): 4 Port ISE Gigabit Ethernet
  MBUS Agent Software version 2.72 (RAM) (ROM version is 3.69)
  Fabric Downloader version used n/a (ROM version is 7.9)
rotgsr-2#dir
Directory of disk0:/
    1  -rw-     6892544   Oct 8 2010 13:38:58 -04:00  c12k-fpd-pkg.120-33.S7.pkg
    2  -rw-    31299072   Oct 8 2010 13:44:50 -04:00  c12kprp-p-mz.120-33.S7.bin
How do i find the correct IOS load to help upgrade to the correct firmwares?  Obviously, the latest 12.0S isn't enough.  And why does the Fabric Downloaded say version n/a?  Did I miss a step?
Thanks,
Greg
667
Views
0
Helpful
0
Replies
CreatePlease to create content