Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1130AG and XP sp3 file copy problem

Hello, we just deployed a cisco wireless solution with WLC4404-100, WCS, and a bunch of 1130AP and I experience some problem with file copy under windows xp. The file copy is working fine with my Ethernet connection however.

The symptom is as follow. I cannot copy large file from a share to the computer. The copy starts then after a while (let's say 30MB copy over a 100MB file) it stops with the error 'File copy error: The network name is no longer available'. When this occurs, I still have my wireless card connected and I can ping my computer from the controller.

I tried to adjust some radio settings (channel, power on the AP I'm connected to) because we have a large wireless network here, but no success. I also update the wireless card driver, create a new SSID, etc. No success at all. However the copy went fine for small file size.

Does anyone here had this issue in the past?

Thanks to all for your help

Theo

Everyone's tags (4)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: 1130AG and XP sp3 file copy problem

Hi Theophile,

1- What version of WLC you are having?

2- Is your server from where you are copying having a 1 Gig interface?

If answer to (2) is yes please try to enter on WLC CLI:

config ap tcp-adjust-mss enable YOURAPNAME 1300

keep us posted.

Serge

Cisco Employee

Re: 1130AG and XP sp3 file copy problem

Hi theophile,

This command was introduced in 6.0 and later.

4.2 is "old" in date but for sure the most stable currently.

Since the transfer stops in the middle with a reference to the share name not being available I would think about broadcasts. By default, broadcasts are blocked on the WLC and this is how windows mostly do file transfers.

If you try to transfer the same file via FTP, would it work ? If yes, I really think the windows network share protocol traffic should be inspected to see if there is a problem with resovling a name or with broadcasts or sth.

Nicolas

9 REPLIES
Cisco Employee

Re: 1130AG and XP sp3 file copy problem

Hi Theophile,

1- What version of WLC you are having?

2- Is your server from where you are copying having a 1 Gig interface?

If answer to (2) is yes please try to enter on WLC CLI:

config ap tcp-adjust-mss enable YOURAPNAME 1300

keep us posted.

Serge

New Member

Re: 1130AG and XP sp3 file copy problem

Hi Serge,

First of all thanks for your answer.

We're using version 4.2.205, I know it's an old one but we are in a process to move to a 7.0 version. The server is connected with its gigabit interface so I'll try the command you gave me, and i'll keep you posted of course

Thanks

New Member

Re: 1130AG and XP sp3 file copy problem

Serge, the command does not exist on  4.2.205. Is there a similar one to adjust the mss?

Thanks, best regards

Cisco Employee

Re: 1130AG and XP sp3 file copy problem

Hi theophile,

This command was introduced in 6.0 and later.

4.2 is "old" in date but for sure the most stable currently.

Since the transfer stops in the middle with a reference to the share name not being available I would think about broadcasts. By default, broadcasts are blocked on the WLC and this is how windows mostly do file transfers.

If you try to transfer the same file via FTP, would it work ? If yes, I really think the windows network share protocol traffic should be inspected to see if there is a problem with resovling a name or with broadcasts or sth.

Nicolas

Purple

Re: 1130AG and XP sp3 file copy problem

  Check things like  speed/duplex between the ap and the switch it is attached to . It should be set as auto and not hardcoded.  Verify the path from the subnet that the ap's are attached  in does not have a network issue between them and the WLC .   Can't imagine anything in the wireless setup that would put that kind of delay in the application.  Just something to check...

New Member

Re: 1130AG and XP sp3 file copy problem

Hi all, I finally found the solution by setting the mtu

in the windows registry. Was set to default (1500), and it worked fine when set at 1400. Thanks to all for your help.

New Member

Re: 1130AG and XP sp3 file copy problem

Serge, we finally upgrade the controller to version 7, and the tcp-mss command fixed the problem too, like setting the MTU in the windows registry.

Best regards

New Member

Re: 1130AG and XP sp3 file copy problem

Can someone explain me how to close the dioscussion as the problem is now fixed? thanks

Cisco Employee

Re: 1130AG and XP sp3 file copy problem

You need to choose the answer that was most appropriate to your problem and mark the thread as answered.

744
Views
0
Helpful
9
Replies
CreatePlease to create content