Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1142 errors out while downloading image

I have a 4402 controller just recently upgraded to code 5.2.178. I have a new 1142 out of the box and I am trying to get it up and running. It finds the controller and starts the image download but then stops with the following error:

capwap_image_proc: problem extracting tar file

It then tries to reconnect to the controller, it finds it and errors out again.

Figured I'd ask for some ideas here before I went to TAC.

Thanks

9 REPLIES
Cisco Employee

Re: 1142 errors out while downloading image

Hmm not much to go on here... You know I collect Martin Guitars (to digress here a bit) and at these Bluegrass festivals I like to attend once in a great while they have a bumper sticker that's pretty popular.. it says... "It takes a village to tune a banjo"... at risk of sounding like the village idiot when you have a problem like that... you simply got to take it apart... meaning you can't tune a guitar or banjo without another one (or tuner etc) so you threw an 1142 out there and it's whining.. ok.. I'm thinking this...

1. Does another 1140 do the same thing (where's the other banjo)

If no, you have a bad AP. If YES then..

2. Have you tried to download a new version of controller code and flash the controller again? Maybe during the process the code it pushes to the AP got corrupt? If so that's why the AP rejects it remember the controller holds that image for the AP.

If you flash it and it still won't talk to the AP.. then what's your network look like.. maybe the image is getting hosed across the network or through something in the network.. break the network down into something easy see if it still fails.. (if it works that's the answer) if it doesn't... time to find another controller.. From the problem description there just isn't enough stuff here to rule out what is broke...

TAC is a good village to help you tune that Banjo but I don't think you need them for this... ..

New Member

Re: 1142 errors out while downloading image

I tried another AP and it does the same thing and give the same error. 1242 and 1252 AP can connect just fine. Being a guitar player myself I can see where you have to take this thing apart. I'm in the process of downgrading to 5.2.157 and see what happens with that.

Re: 1142 errors out while downloading image

I can tell you that it SHOULD work. I am using a 4402 with 5.2.178.0. I just took an 1142 out of the box, and it worked fine. This is all in a lab environment, so my network is extremely simple/direct. Power was provided by the wall wart, though, not PoE.

Hall of Fame Super Gold

Re: 1142 errors out while downloading image

Michael,

While you have the 1140 still there, can you console into the AP and find out the status of the flash? If you are running the RCV file, can you type the following commands:

clear lwapp private

clear lwapp ap controller ip address

clear lwapp hostname

clear lwapp ip address

Re: 1142 errors out while downloading image

Make sure that you followed the upgrade path on the controller properly. Including the ER boot strap upgrades. Also make sure the date and time are correct on the controller or the file extraction will fail due to securtiy certificate issues.

New Member

Re: 1142 errors out while downloading image

I was originally running 4.2.176, so I could upgrade directly to 5.2.178. I do not have any 1522 APs so I I don't think I need to upgrade the bootstrap image. The controller time is in sync with our time server. I downgraded the controller to 5.2.157 and the AP downloads the image fine. I tried to redownloading 5.2.178 again and am still having the same problem.

As far as our network, I have our controllers connected to a 3750-24T running 12.2(25)SEB4. From there we are allowing only wireless traffic and vlans to be passed to the controllers. The 1142 is connected to a 6509 and that is routed to the 3750. 1242 and 1252 APs connect and download just fine so I don't think it's a routing issue.

Hall of Fame Super Gold

Re: 1142 errors out while downloading image

Hi Michael,

When you tried another AP, did you plug it into the same VLAN segment as the WLC?

"I don't think I need to upgrade the bootstrap image."

You're right, to solve this problem, I don't think you need to, however, there are alot of patches the new bootstrap fixes/addresses with the old bootstrap. It's worthwhile upgrading the bootstrap when you are able to. (I know it's a pain and a hassle after doing those bootup.)

New Member

Re: 1142 errors out while downloading image

After submitting a TAC request and doing debugs on the controller and APs and reviewing the configs on our 3750 stack and 6500's this was filed as a bug.

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsy88329

CSCsy88329

1142 fails on downloading code from controller with Bad Record MAC alert

Symptom:

LAp 1142 will not downlaod code from controller running 5.2.xxx with error Bad Record MAC alert and Invalid CAPWAP states

Conditions:

WLC running 5.2.xxx connected to stacked 3750 switch. Initially had LAG enabled and controller ports connecting to two different stacks in same switch. Later had no LAG and only 1 port connecting to switch and AP on same switch and subnet as controller nad AP would still not join

Thanks to all who offered suggestions for me to try.

Now I'm trying to figure out what I'm going to do with these 30 1142's I have until they get this issue fixed.

Re: 1142 errors out while downloading image

New versaion of 5.2 just a bout 4-6 weeks away man. Just hold on.

311
Views
0
Helpful
9
Replies
CreatePlease to create content