Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

1230AG not able to stay joined to controller

Hi,

I have multiple 1230AG wireless access point in autonomous mode that I am migrating to lightweight mode so that a 4402 controller can manage them.

I already migrated 4 of those APs with no problems using the Upgrade Tool version 3.4 and now I have one that just refused to upgrade version.

I ran the upgrade tool for this AP alone with the same parameters as others. It is now on lightweight version 12.3.7-JX9

The upgrade procedure went smoothly, the SSC was created on the AP and added to the authorised list on the controller.

The AP boots up, gets an IP by DHCP, tries the controller via DNS, gets to it.

It joins it then disconnects. Its FastEthernet interface keeps doing down/up every 90 seconds or so.

In my controller logs I see:

*SNMPTask: Feb 22 19:39:17.135: %LWAPP-3-INVALID_SLOT: spam_api.c:711 Invalid slot identifier (0) - ; AP 00:13:.........

*spamReceiveTask: Feb 22 19:39:13.150: %LWAPP-3-PAYLOAD_MISSING: spam_lrad.c:5484  Join request does not contain BOARD_DATA payload 

*spamReceiveTask: Feb 22 15:33:50.566: ssphmPublicKeyEncrypt: successfully encrypted, out is 256 bytes

...

*sshpmLscTask: Feb 22 15:36:24.582: sshpmLscTask: LSC Task received a message 4

*spamReceiveTask: Feb 22 15:37:22.948: sshpmFreePublicKeyHandle: called with 0x......

*spamReceiveTask: Feb 22 15:37:22.948: sshpmFreePublicKeyHandle: freeing public key

*spamReceiveTask: Feb 22 15:37:22.948: 00:13:c3:07:d9:04 Join Priority Processing status = 1, Incoming Ap's Priority 0, MaxLrads = 50,joined Aps =14

*spamReceiveTask: Feb 22 15:37:32.951: Could not find BoardDataPayload

The debugs on the controller dont give me any of the usual no valid certificate or other error messages that the troubleshooting guides talk about...

*spamReceiveTask: Feb 22 15:33:50.560: sshpmGetIssuerHandles: SSC Key Hash is .......

I tried to remove the SSC hash from the auth list and re-add it and that didn't change anything.

The AP sent out so many join requests to the controller but was never able to stay as joined. It is not able to update its firmware...

I changed the Ethernet cable just in case.

Next thing is: I will retry the upgrade procedure (go back to autonomous then back to lightweight...)

Anyone been through this? any ideas?

Thanks,

Patrick Moubarak

5 REPLIES

Re: 1230AG not able to stay joined to controller

Patrick,

Do you have one port or both active on your 4402? If both, please confirm that you have issued the following command to the upstream switch if it is a catalyst switch:

switch# port-channel load-balance src-dst-ip

I've seen APs, especially 1230s, have trouble joining when the load balancing algorithm is not set as above on the wlc-connected switch.

Justin

1230AG not able to stay joined to controller

Hi Justin,

I have both ports connected to an upstream 3750G stack. The port channel load balancing method is already set to src-dst-ip...

Patrick

Hall of Fame Super Gold

1230AG not able to stay joined to controller

22 February????  Are you sure your WLC has the correct time?

1230AG not able to stay joined to controller

The WLC is configured for NTP but did not have the correct timezone.

I adjusted that but I still have the same issue with that 1231AG

1230AG not able to stay joined to controller

Patrick,

Consider trying the upgrade again. When you go from the lwapp recovery image back to the autonomous image, use a current autonomous image for the 1230, such as 12.3.8-JEE.

While it is in autonomous mode, make sure you see both an 802.11g and 802.11a radio and that they are both operational.

Justin

580
Views
0
Helpful
5
Replies