Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

1841 in Universal Client Mode

I am trying to make my 1841 Router (with HWIC-AP card) work in Universal Client Mode (not bridging!!). I have tried to configure as per this (there seems to be very little document on this out there :( )

http://www.cisco.com/en/US/docs/routers/access/1800/wireless/configuration/guide/s37rf.html#wp1134667

From the 1242AP, I am only able to ping to the dot11 interface on the Router, not to the Fa 0/0 or the Router

Any suggestions will be helpful, Thanks

Configuration on 1242AP:

=======================

dot11 ssid Cisco

authentication open

!

bridge irb

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid Cisco

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

station-role root access-point

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

hold-queue 160 in

!

interface BVI1

ip address 192.168.1.10 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.254

!

bridge 1 protocol ieee

bridge 1 route ip

Configuration on 1841 Router:

============================

dot11 ssid Cisco

authentication open

infrastructure-ssid

!

ip dhcp excluded-address 172.16.1.1

!

ip dhcp pool BMX

network 172.16.1.0 255.255.255.0

default-router 172.16.1.1

!

!

interface FastEthernet0/0

ip address 172.16.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

duplex auto

speed auto

no keepalive

!

interface Dot11Radio0/0/0

ip address 192.168.1.70 255.255.255.0

ip nat outside

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

!

ssid Cisco

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

station-role non-root

!

ip route 0.0.0.0 0.0.0.0 Virtual-Dot11Radio0

ip nat inside source list 1 interface Virtual-Dot11Radio0 overload

!

access-list 1 permit any

!

  • Other Wireless - Mobility Subjects
2 REPLIES

Re: 1841 in Universal Client Mode

under the SSID on the 1242, add infrastucture-ssid optional

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: 1841 in Universal Client Mode

This problem has been solved now. It seems to be a minor NATing issue. I removed permit any and replaced with inside subnet in the access-list. According to Cisco, you do not configure access lists referenced by NAT commands with permit any. Using permit any can result in NAT consuming too many router resources which can cause network problems.

ip route 0.0.0.0 0.0.0.0 192.168.1.254

!

ip nat inside source list 1 interface Virtual-Dot11Radio0 overload

!

access-list 1 permit 172.16.1.0 0.0.0.255

!

511
Views
1
Helpful
2
Replies
This widget could not be displayed.