Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

3602i Errors in log, bad throughput

I just acquared a 3602i.  It was running lightweight, but I changed it to autonomous.

From the start I notced absomal throughput when only 10-20 feet away, bouncing from 0 to 7 Mb/s when using iperf over a 30 second period.  If I used the same client on my 3502, I get a solid consistant throughput of 37 Mb/s.

When I looked at the logs, I noticed the following section:

  1. Sep 29 11:18:13 MDT: %DOT11-6-ASSOC: Interface Dot11Radio0, Station ap 001f.3b05.ecd7 Associated KEY_MGMT[WPAv2 PSK]
  2. Sep 29 11:18:17 MDT: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 001f.3b05.ecd7 Reason: Sending station has left the BSS
  3. Sep 29 17:18:25.552: Cmd Timeout After 12s
  4. Sep 29 11:18:25 MDT: %DOT11-6-GEN_ERROR: Error on Dot11Radio0 -
  5. Radio interface bus down --
  6. -Traceback= 219A458z 2771628z 2FBB980z 276FBC8z 2770094z 2772818z 2329810z 230E6D8z
  7. Sep 29 11:18:25 MDT: %LINK-5-CHANGED: Interface Dot11Radio0, changed state to resetPCI reset port 0
  8. Sep 29 17:18:26.863: soap_pci_reconfig_radio: radio id 0
  9. Sep 29 11:18:26 MDT: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to down
  10. Sep 29 11:18:32 MDT: %LINK-6-UPDOWN: Interface Dot11Radio0, changed state to up
  11. Sep 29 17:18:32.921: dot11_mgmt: bad cookie returned from driver for mac 001f.3b05.ecd7(expected 0x0, got 0x843E6D4) - force driver to delete client

Those errors are none that I have seen before.

Ideas?  I have an idea what is wrong, but I wanted some feedback before suggesting anything.  The performance is bad with more than just this specific client that I'm testing with.

Thanks

Everyone's tags (3)
7 REPLIES
VIP Purple

3602i Errors in log, bad throughput

What IOS version you running here ? Also compare "show dot11 associations " output with 3602 & 3502 when client connected. Specially "current rate" parameter.

Some of the error msg like hardware related like "Radio interface bus down" etc. I would upgrade the software & see.

HTH

Rasika

**** Pls rate all useful responses ****

New Member

Re: 3602i Errors in log, bad throughput

3602i only should work in lap mode, what IOS you used to covert it to AP mode?

Sent from Cisco Technical Support iPad App

New Member

Re: 3602i Errors in log, bad throughput

I'm running the latest autonomous code (July 31st 2013) - ap3g2-k9w7-xx.152-4.JA1 , but I was also running an old one and had the same errors as I originally posted.

I finally got around the testing again with my two APs

On my troubled 3602i:

ap#show dot11 associations 001f.3b05.ecd7

Address           : 001f.3b05.ecd7     Name             : ap

IP Address        : 172.16.1.91        IPv6 Address        : ::

Gateway Address   : 0.0.0.0

Netmask Address   : 0.0.0.0            Interface        : Dot11Radio 0

Bridge-group        : 1

reap_flags_1        : 0x0     ip_learn_type       : 0x0       transient_static_ip : 0x0

Device            : ccx-client         Software Version : NONE

CCX Version       : 4                  Client MFP       : Off

State             : Assoc              Parent           : self

SSID              : InOut2

VLAN              : 100

Hops to Infra     : 1                  Association Id   : 1

Clients Associated: 0                  Repeaters associated: 0

Tunnel Address    : 0.0.0.0

Key Mgmt type     : WPAv2 PSK          Encryption       : AES-CCMP

Current Rate      : m13b               Capability       : WMM ShortHdr ShortSlot

Supported Rates   : 1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0-2 m1-2 m2-2 m3-2 m4-2 m5-2 m6-2 m7-2 m8-2 m9-2 m10-2 m11-2 m12-2 m13-2 m14-2 m15-2

Voice Rates       : disabled           Bandwidth        : 20 MHz

Signal Strength   : -59  dBm           Connected for    : 167 seconds

Signal to Noise   : 34  dB            Activity Timeout : 20 seconds

Power-save        : Off                Last Activity    : 0 seconds ago

Apsd DE AC(s)     : NONE

Packets Input     : 119034             Packets Output   : 55189

Bytes Input       : 174092109          Bytes Output     : 3603931

Duplicates Rcvd   : 18862              Data Retries     : 11745

Decrypt Failed    : 1                  RTS Retries      : 0

MIC Failed        : 0                  MIC Missing      : 0

Packets Redirected: 0                  Redirect Filtered: 0

IP source guard failed : 0             PPPoE passthrough failed : 0

DAI failed : IP mismatch  : 0             src MAC mismatch : 0             target MAC mismatch : 0     

Existing IP failed :  0              New IP failed :  0

11w Status       : Off

Session timeout   : 0 seconds

Reauthenticate in : never

And I have the following errors during my iperf test:

Oct  6 20:14:23 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 8 AES-CCMP TSC replays

Oct  6 20:14:35 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 5 AES-CCMP TSC replays

Oct  6 20:14:46 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 3 AES-CCMP TSC replays

Oct  6 20:14:53 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 16 AES-CCMP TSC replays

Oct  6 20:15:00 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 11 AES-CCMP TSC replays

Oct  6 20:15:07 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 8 AES-CCMP TSC replays

Oct  6 20:15:14 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 5 AES-CCMP TSC replays

Oct  6 20:15:21 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 11 AES-CCMP TSC replays

Oct  6 20:15:28 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 13 AES-CCMP TSC replays

Oct  6 20:15:35 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 23 AES-CCMP TSC replays

Oct  6 20:16:14 MDT: %DOT11-4-CCMP_REPLAY: Client 001f.3b05.ecd7 had 19 AES-CCMP TSC replays

While on my 3502i I have much better success:

ap#show dot11 associations  001f.3b05.ecd7

Address           : 001f.3b05.ecd7     Name             : ap

IP Address        : 172.16.1.91        IPv6 Address        : ::

Gateway Address   : 0.0.0.0

Netmask Address   : 0.0.0.0            Interface        : Dot11Radio 0

Bridge-group        : 1

reap_flags_1        : 0x0     ip_learn_type       : 0x0       transient_static_ip : 0x0

Device            : ccx-client         Software Version : NONE

CCX Version       : 4                  Client MFP       : Off

State             : Assoc              Parent           : self

SSID              : InOut

VLAN              : 100

Hops to Infra     : 1                  Association Id   : 11

Clients Associated: 0                  Repeaters associated: 0

Tunnel Address    : 0.0.0.0

Key Mgmt type     : WPAv2 PSK          Encryption       : AES-CCMP

Current Rate      : m15-               Capability       : WMM ShortHdr ShortSlot

Supported Rates   : 1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0-2 m1-2 m2-2 m3-2 m4-2 m5-2 m6-2 m7-2 m8-2 m9-2 m10-2 m11-2 m12-2 m13-2 m14-2 m15-2

Voice Rates       : disabled           Bandwidth        : 20 MHz

Signal Strength   : -56  dBm           Connected for    : 173 seconds

Signal to Noise   : 40  dB            Activity Timeout : 20 seconds

Power-save        : Off                Last Activity    : 0 seconds ago

Apsd DE AC(s)     : NONE

Packets Input     : 154059             Packets Output   : 79315

Bytes Input       : 225124589          Bytes Output     : 5124766

Duplicates Rcvd   : 4                  Data Retries     : 3044

Decrypt Failed    : 1                  RTS Retries      : 0

MIC Failed        : 0                  MIC Missing      : 0

Packets Redirected: 0                  Redirect Filtered: 0

IP source guard failed : 0             PPPoE passthrough failed : 0

DAI failed : IP mismatch  : 0             src MAC mismatch : 0             target MAC mismatch : 0

Existing IP failed :  0              New IP failed :  0

11w Status       : Off

Session timeout   : 0 seconds

Reauthenticate in : never

> 3602i only should work in lap mode, what IOS you used to covert it to AP mode?

Autonomous code has been released by Cisco, it's available from the support/download page.  While I totally understand these classes of lighweight radios were meant to only be used this way and that autonomous was for surveying with a limited feature set, my 3502i has worked flawless for 4+ months.

Also, I also don't think the errors I'm seeing are a result of using the Autonomous mode, these seem like much lower level of errors that woudl impact your ability to even do a proper suvrey.

New Member

3602i Errors in log, bad throughput

Endaff,

Did you ever find an fix for this (other than switching to the 3502)?  We have been having the same issue for quite a while.  We are using 2602 radios for both the RB and NRB.  Switching from 1242's radios to the 2602's seemed to work for a bit, but the same logs have shown back up, and the NRB's drop there assococation periodically, but do usually reassociate on their own.  The problem is it is causing troubles with our end devices connecting to the NRB while the connection is down.  Any information you can provide would be appreciated.  Thanks

Hall of Fame Super Gold

3602i Errors in log, bad throughput

Don't use IOS version 15.0, if possible.  Use 12.4.

VIP Purple

3602i Errors in log, bad throughput

Hi Endaf,

Please try to add the infrastructure-client command root access point radio stops the message.

If this is only for a  specific client looks like , client related issue. That MAC OUI look like an intel card, ensure that it is running the latest driver.Hope that helps.

https://discussions.apple.com/thread/3042800?start=165&tstart=0

Hope it helps.

Regards

New Member

3602i Errors in log, bad throughput

No, I have not resolved this.  I havn't had time to work on this lately, but I'm in the process of moving this specific radio to a WLC enviorment to test again.

I'm trying to determine if this is a hardware fault or firmware issue.

1251
Views
0
Helpful
7
Replies
CreatePlease to create content