Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3G-HSPA HWIC configuration - Any examples?

Hi

I Have a 1841 ISR router with a HWIC 3G-HSPA.

I configured according to Cisco doc, but I can no get the interface going up.

I don't know if there is aproblem of configuration or a ISP authentication problem

Here is my config

Building configuration...

Current configuration : 1784 bytes

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

dot11 syslog

ip source-route

!

!

!

!

!

ip cef

multilink bundle-name authenticated

!

chat-script internet "" "ATDT*98#" TIMEOUT 30 CONNECT

chat-script gsm "" "ATDT*99*#7" TIMEOUT 60 "CONNECT"

crypto pki token default removal timeout 0

!

!

!

controller Cellular 0/1

!

!

!

!

!

interface FastEthernet0/0

ip address 10.0.0.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

!

interface Serial0/0/1

no ip address

shutdown

!

interface Cellular0/1/0

no ip address

ip nat outside

ip virtual-reassembly in

encapsulation ppp

load-interval 60

dialer in-band

dialer-group 1

async mode interactive

no fair-queue

!

interface Cellular0/1/1

no ip address

encapsulation ppp

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer string gsm

dialer persistent

dialer-group 1

no fair-queue

ppp authentication chap callin

ppp chap hostname dummy

ppp chap password 0 dummy

ppp ipcp dns request

no cdp enable

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

logging esm config

access-list 1 permit any

!

!

control-plane

!

!

line con 0

line aux 0

line 0/1/0

exec-timeout 0 0

script dialer gsm

login

modem InOut

no exec

transport input all

speed 237000

line 0/1/1

no exec

speed 237000

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

*********** Cellular INFO

Router#sho cellular 0/1/0 all

Hardware Information

====================

Modem Firmware Version = K1_0_2_18AP C:/WS/F

Modem Firmware built = 12/29/08

Hardware Version = 1.0

International Mobile Subscriber Identity (IMSI) = 734021099999999

International Mobile Equipment Identity (IMEI) = 011955009999999

Integrated Circuit Card ID (ICCID) = 8958020909999999999

Mobile Subscriber International Subscriber

IDentity Number (MSISDN) =

Factory Serial Number (FSN) = D66162036221021

Modem Status = Online

Current Modem Temperature = 37 deg C, State = Normal

PRI SKU ID = 9992680, SKU Rev. = 1.1

Profile Information

====================

Profile 7 = INACTIVE

--------

PDP Type = IPv4

Access Point Name (APN) = gprsweb.digitel.ve

Authentication = None

Username: , Password:

* - Default profile

Data Connection Information

===========================

Data Transmitted = 0 bytes, Received = 0 bytes

Profile 1, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 2, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 3, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 4, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 5, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 6, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 7, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 8, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 9, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 10, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 11, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 12, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 13, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 14, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 15, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Profile 16, Packet Session Status = INACTIVE

        Inactivity Reason = Normal inactivate state

Network Information

===================

Current Service Status = Normal, Service Error = None

Current Service = Combined

Packet Service = EDGE (Attached)

Packet Session Status = Inactive

Current Roaming Status = Home

Network Selection Mode = Automatic

Country = VEN, Network = DIGITEL

Mobile Country Code (MCC) = 734

Mobile Network Code (MNC) = 2

Location Area Code (LAC) = 3002

Routing Area Code (RAC) = 3

Cell ID = 1851

Primary Scrambling Code = 0

PLMN Selection = Automatic

Registered PLMN =  , Abbreviated =

Service Provider =

Radio Information

=================

Radio power mode = ON

Current Band = GSM 900, Channel Number = 104

Current RSSI = -65 dBm

Band Selected = GSM all band

Modem Security Information

==========================

Card Holder Verification (CHV1) = Disabled

SIM Status = OK

SIM User Operation Required = None

Number of Retries remaining = 3

Everyone's tags (2)
2 REPLIES
Silver

Re: 3G-HSPA HWIC configuration - Any examples?

Hi Esteban,

there are a couple of changes in config that may help:

- when you configure the chat-script, 99 means use the default profile (= #1) while 98 means use a specific one.

chat-script gsm "" "ATDT*99#" TIMEOUT 60 "CONNECT"  <<< use default profile

chat-script gsm "" "ATDT*98*7#" TIMEOUT 60 "CONNECT"   <<< use profile #7

- the dialer interface is configured for dialer-group 1, but you did not configure any dialer-list 1. You should add:

access-list 1 permit any

dialer-list 1 protocol ip list 1

- in general, you don't necessarily need a dialer interface over the cellular, as the cellular interface already behaves like a dialer. Personally I'd move all the dialer config under the cellular, and remove the dialer interface, it simplifies the troubleshooting.

Let me know if those changes help.

If not, can you capture the output of

- deb ppp nego

- deb dialer

- deb chat

Cheers

Marco

New Member

Re: 3G-HSPA HWIC configuration - Any examples?

Thanks!

I'll change the config and tell you if OK

2514
Views
0
Helpful
2
Replies
CreatePlease login to create content