Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

3rd Party SSL Certificate Issue - Wont Show As 3rd Party!

Hi,

To keep the story short we have a root certificate from Verisign which we are trying to upload onto a customer's 4402 WLC running 4.1.185.0. This certificate is intended to stop the security message appearing when attaching to the Guest SSID using web auth. When we upload the cert onto the 4402 it accepts it but says its locally generated instead of 3rd party...

We have uploaded the same certificate onto our office WLC which is a 4402 running 4.2.99 and it accepts it as 3rd party. I also have a spare 4402 in our staging area and have put both 4.1.185.0 and 4.2.99 on it and uploaded the certificate, it says locally generated on this one on both versions of software!

We then tried copying the config from our office WLC onto the staging WLC, with both running software 4.2.99. The staging WLC then sees the certificate as 3rd party....So, the only thing I can summise is that the issue lies with some configuration bug on the controller. There must be some configuration setting which causes certificates to be seen as locally generated instead of 3rd party but what is it? Has anyone seen this before?

FYI we have also tried another certificate from Digicert which does exactly the same thing....

Thanks in advance

1 REPLY
Hall of Fame Super Red

Re: 3rd Party SSL Certificate Issue - Wont Show As 3rd Party!

Hi SD,

Have a look at this good doc supplied by Wayne;

http://www.cisco.com/application/pdf/paws/70584/csr_wlc.pdf

Hope this helps!

Rob

176
Views
0
Helpful
1
Replies
CreatePlease to create content