Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

881-W wifi clients not getting DHCP

I'm monkeying around with an 881-W. Clients can associate and authenticate to ssid 'test', but they cannot get a DHCP address. Clients plugged into f 0 - 3 get DHCP addresses just fine.

I've looked at a lot of different guides, ran debugs etc. When wifi clients make DHCP requests the server never gets them. So there must be some IRB thing going on. Been banging my head on this wall for about an hour and figured it was time for an assist.

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: 881-W wifi clients not getting DHCP

I've never played with an 881W before, but it looks to be like GigabitEthernet0 on the internal AP should be a trunked interface, not a routed link. The Gig0 interface on the router is a trunked link with VLAN 10 set to native. Try using the same configuration on the AP side. As for the IP address, move that over to the BVI1 interface.

So configure:

int gig0

no ip address

no bridge-group 1

int gig0.10

encapsulation dot1q 10 native

bridge-group 1

int bvi1

ip add 192.168.1.2 255.255.255.0

5 REPLIES
Silver

Re: 881-W wifi clients not getting DHCP

I've never played with an 881W before, but it looks to be like GigabitEthernet0 on the internal AP should be a trunked interface, not a routed link. The Gig0 interface on the router is a trunked link with VLAN 10 set to native. Try using the same configuration on the AP side. As for the IP address, move that over to the BVI1 interface.

So configure:

int gig0

no ip address

no bridge-group 1

int gig0.10

encapsulation dot1q 10 native

bridge-group 1

int bvi1

ip add 192.168.1.2 255.255.255.0

New Member

Re: 881-W wifi clients not getting DHCP

Nice, that did the trick. You know what was a killer on this one? All of the documentation I found specifically directed to configure the gig0 interface as I had. At any rate, thank you very much.

It's obviously time for me to bone up on IRB.

Silver

Re: 881-W wifi clients not getting DHCP

I hear you, Cisco documentation for configuring wireless modules in routers is seriously lacking. I spent almost a full day trying to configure one the first time I did it.

New Member

Re: 881-W wifi clients not getting DHCP

I've got a similar issue with my setup, but the IOS responds telling me that interface wlan-gigabitethernet0 does not support bridging...um what?

881W-Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

881W-Router(config)#int wlan-gig0

881W-Router(config-if)#switch mode access

881W-Router(config-if)#bridge-group 1

Wlan-GigabitEthernet0 does not support bridging

881W-Router(config-if)#end

New Member

881-W wifi clients not getting DHCP

I am having the exact same problem as you Scott. Did you ever resolve the issue?

My setup, but the IOS responds telling me that interface wlan-gigabitethernet0 does not support bridging:

881W-Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

881W-Router(config)#int wlan-gig0

881W-Router(config-if)#switch mode access

881W-Router(config-if)#bridge-group 1

Wlan-GigabitEthernet0 does not support bridging

881W-Router(config-if)#end

Anyone help?

1753
Views
0
Helpful
5
Replies