Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AIR-AP1042N-N-K9 Issue

Hi,

I'm hoping someone can help me figure out what's going on with the Cisco AIR-AP1042N-N-K9 I've been trying to deploy.

It's a pretty simple setup on the clients site. There's a Cisco 887, a couple of PC and the AP1024 that's giving me issues. Out of the 80 odd sites we support with this setup, this is the only AP1024 I'm having issues with.

I use a standard config (and it's worked on the other APs) and only change the IP address and user credentials on it. I connect via console, copy the config, save it and do a quick test that I can connect to the SSID - it looks all good.

When it was deployed to the site, they were having issues connecting to it, so I jumped onto the 887, then connected to the AP. I was able to log on, and enter priviledged exec mode, but when I did a show run, the AP froze for a few minutes, then kicked me off.

I could connect to the AP again, but everytime I tried to do anything that really required an output from the AP, it kept freezing.

A restart didn't resolve the issue.

The AP was returned to me and I conencted to it via the console again, and it worked fine. I didn't have any issues any commands.

I decided to replicate the environment, and connect to the AP through the router, and it froze again.

I'm kinda at a loss as to what the issue is. I did try to set the speed and duplex on the ports to match incase that was the issue, but it's still occuring.

The config is below:

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname <APname>

!

logging rate-limit console 9

enable secret xxxxxxxxx

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

aaa session-id common

!

!

dot11 syslog

!

dot11 ssid xxxxxxxxx

   authentication open

   authentication key-management wpa version 2

   no guest-mode

   wpa-psk ascii 0 xxxxxxxx

!

!

!

no username Cisco password 0 Cisco

username xxxxxx privilege 15 password 0 xxxxxxxxxx

!

!

bridge irb

!

!

interface Dot11Radio1

no ip address

no ip route-cache

no shutdown

!

encryption mode ciphers aes-ccm

!

ssid xxxxxxxxxxxxx

!

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

no keepalive

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.20.xx.xx 255.255.255.224

no ip route-cache

!

ip default-gateway 10.20.xx.xx

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

logging synchronous

line vty 0 4

!

end

!

Any help is appreciated

Cheers

Andrew

4 REPLIES
Bronze

AIR-AP1042N-N-K9 Issue

If I've understood you correctly, you are having only problems connecting to AP via Ethernet interface for management? Wireless clients are did not experience any problems when connected to SSID (while AP was in the site). Right?

What is the version of AP IOS?

New Member

AIR-AP1042N-N-K9 Issue

Actually the wireless clients were having issues. They seemed to  connect to the AP but they could get out to the internet. When I went to  log onto the AP and investigate, I had issues managing the AP via  Ethernet.

The AP Version Details are below:

sh version

Cisco IOS Software, C1040 Software (C1140-K9W7-M), Version 12.4(25d)JA1, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Thu 11-Aug-11 02:58 by prod_rel_team

ROM: Bootstrap program is C1040 boot loader

BOOTLDR: C1040 Boot Loader (C1140-BOOT-M) Version 12.4(23c)JA6, RELEASE SOFTWARE (fc1)

AP uptime is 16 hours, 46 minutes

System returned to ROM by power-on

System image file is "flash:/c1140-k9w7-mx.124-25d.JA1/c1140-k9w7-mx.124-25d.JA1"

Cheers

Andrew

Bronze

AIR-AP1042N-N-K9 Issue

I'm sorry, I had a potential version, but it is now does not fit your case...

Your configuration looks correct ...

I get lost in conjecture, but I would have researched this problem so (unless of course you have the time for it, if not, I would first upgrade the AP IOS to a more recent):

  • is this issue layer 2 or layer 3 - Can wireless client get DHCP ip address? Is the wireless clients can reach the default gateway, each other via AP? Is any issues managing the AP from the same subnet as BVI1?
  • is there any connectivity issues - interface errors, counters. etc...

AIR-AP1042N-N-K9 Issue

You cannot use HTTPS file transfer to upgrade to  Cisco IOS Release 15.2(2)JA from previous releases. Because of the image  size for this release, you must use TFTP or FTP file transfer for the  upgrade. Refer to the upgrade instructions at this URL:

http://www.cisco.com/en/US/docs/wireless/access_point/12.4_10b_JA/configuration/guide/scg12410b-chap20-firmware.html#wp1035507

594
Views
0
Helpful
4
Replies