Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Aironet 1240AG unable to connect to 802.11b cards

I have numerous 802.11b cards that will not see the wireless network but 802.11g see it fine. I have set it up per the directions to make the 1.0, 2.0, 5.5, and 11.0 as the basic rate. What else do I need to do? Thank you for your help.

16 REPLIES
Silver

Re: Aironet 1240AG unable to connect to 802.11b cards

That should be all you need to do. Also, make sure you're not using WPA with AES for encryption, as most b-cards won't support this.

At this point you need to isolate whether it's a problem with the access point or a problem with the cards. See if you can find another access point or wireless router, and see if the b-cards can connect.

If you can post your configuration, that would probably help us troubleshoot.

Community Member

Re: Aironet 1240AG unable to connect to 802.11b cards

I am not useing WPA. The cards can access other access points. Here is my config file and thank you for all of your help:

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname GCPD

!

!

aaa new-model

!

!

aaa group server radius rad_eap

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login default local

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa accounting network acct_methods start-stop group rad_acct

!

aaa session-id common

!

!

!

dot11 ssid gcpd

authentication open

guest-mode

!

dot11 network-map

power inline negotiation prestandard source

!

!

username admin privilege 15 password xxx

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 128bit xxx transmit-key

encryption mode wep mandatory

!

ssid gcpd

!

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption key 1 size 128bit xxx transmit-key

encryption mode wep mandatory

!

ssid gcpd

!

dfs band 3 block

speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.208.xx.xx 255.255.255.0

no ip route-cache

!

ip default-gateway 10.208.xx.xx

ip http server

ip http authentication aaa

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip radius source-interface BVI1

radius-server local

nas 10.208.48.252 key xxx

!

radius-server attribute 32 include-in-access-req format %h

radius-server vsa send accounting

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

end

Silver

Re: Aironet 1240AG unable to connect to 802.11b cards

Try the following in config mode:

dot0

channel 1

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

See if that works. For some reason this configuration is missing under dot11Radio0. Feel free to use a channel other than 1 if desired.

Community Member

Re: Aironet 1240AG unable to connect to 802.11b cards

I am sorry to ask this but I am a point and click guy. To perform what you want me to do I will need to log into the device through a Telnet session right? Then once logged in I type config and then start typing one line at a time and enter after each one? Sorry for the neophyte questions but I am not a strong Cisco guy.

Community Member

Re: Aironet 1240AG unable to connect to 802.11b cards

It might be that Your old cards dont support short preamble.

Try disabling short preamble for the 802.11b radio from the GUI or from the CLI:

Step 1

configure terminal

Step 2

interface dot11radio 0

Step 3

no preamble-short

Step 4

end

Step 5

copy running-config startup-config

Short preambles are enabled by default.

Community Member

Re: Aironet 1240AG unable to connect to 802.11b cards

Thank you. I will try that and post my results.

Silver

Re: Aironet 1240AG unable to connect to 802.11b cards

Sorry for not responding for several days, I somehow missed that you had responded. Disabling short preamble is a good idea as well.

When you log in, you actually type "config t", t being short for terminal. Let me know how it goes!

Community Member

Re: Aironet 1240AG unable to connect to 802.11b cards

No problem at all. I tried what sanamon suggested but it did not work. When trying to type the first line of yours I would get an error after the dot0. The error is invalad entry pointed at the 0. Below is my config file now. Thank you for your help.

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname GCPD

!

!

aaa new-model

!

!

aaa group server radius rad_eap

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login default local

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa accounting network acct_methods start-stop group rad_acct

!

aaa session-id common

!

!

!

dot11 ssid gcpd

authentication open

guest-mode

!

dot11 network-map

power inline negotiation prestandard source

!

!

username admin privilege 15 password 7 0114050D4B1C0701

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 128bit 7 BC29783FA0A56C1897485E061D68 transmit-key

encryption mode wep mandatory

!

ssid gcpd

!

no preamble-short

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption key 1 size 128bit 7 426FE03F299DB148A7254A7F123C transmit-key

encryption mode wep mandatory

!

ssid gcpd

!

dfs band 3 block

speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.208.xx.xx 255.255.255.0

no ip route-cache

!

ip default-gateway 10.208.xx.xx

ip http server

ip http authentication aaa

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip radius source-interface BVI1

radius-server local

nas 10.208.xx.xx key 7 08264F5E0D

!

radius-server attribute 32 include-in-access-req format %h

radius-server vsa send accounting

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

end

Silver

Re: Aironet 1240AG unable to connect to 802.11b cards

That's totally my fault. The command line should read "int dot0". I must have been sleepy when writing that out :D

Community Member

Re: Aironet 1240AG unable to connect to 802.11b cards

I input the info as you suggested unfortunatly it still does not work. I will paste my config agian but I do not see you had me configure. Do I need to do something to save the config? Thank you so much for your help.

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname GCPD

!

!

aaa new-model

!

!

aaa group server radius rad_eap

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login default local

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization exec default local

aaa accounting network acct_methods start-stop group rad_acct

!

aaa session-id common

!

!

!

dot11 ssid gcpd

authentication open

guest-mode

!

dot11 network-map

power inline negotiation prestandard source

!

!

username admin privilege 15 password 7 0114050D4B1C0701

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 128bit 7 BC29783FA0A56C1897485E061D68 transmit-key

encryption mode wep mandatory

!

ssid gcpd

!

no preamble-short

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption key 1 size 128bit 7 426FE03F299DB148A7254A7F123C transmit-key

encryption mode wep mandatory

!

ssid gcpd

!

dfs band 3 block

speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.208.xx.xx 255.255.255.0

no ip route-cache

!

ip default-gateway 10.208.xx.xx

ip http server

ip http authentication aaa

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip radius source-interface BVI1

radius-server local

nas 10.208.xx.xx key 7 08264F5E0D

!

radius-server attribute 32 include-in-access-req format %h

radius-server vsa send accounting

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

!

end

Community Member

Re: Aironet 1240AG unable to connect to 802.11b cards

Are You sure the old cards support 128bit WEP? Some cards only supported 48/64 Bit WEP (such as the Orinoco silver cards etc)

From the config I can see that long preambles are now configured.

Community Member

Re: Aironet 1240AG unable to connect to 802.11b cards

Yes. They were connected to an Aironet 1200 series with 128bit WEP before it died. I really apperciate your help.

Hall of Fame Super Silver

Re: Aironet 1240AG unable to connect to 802.11b cards

Are your clients configured with the wep key on index 1 and not on 2,3, or 4? So even with an ssid that has no encryption at all, your clients still can't connect?

-Scott
*** Please rate helpful posts ***
Community Member

Re: Aironet 1240AG unable to connect to 802.11b cards

That was a good question and yes they are configured on index 1. I am just going to get the users new wireless cards. I have already put more time in this than the cost of the new cards. Thank everyone for all of your help. How do I need to close this thread.

Hall of Fame Super Silver

Re: Aironet 1240AG unable to connect to 802.11b cards

You don't need to close this thread... it will eventually work its way down the page :)

-Scott
*** Please rate helpful posts ***
Community Member

Re: Aironet 1240AG unable to connect to 802.11b cards

In that case you might want to turn short preamble back on again as this increases throughput...

Regards,

Jonas

274
Views
0
Helpful
16
Replies
CreatePlease to create content