Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Aironet 1262N + Multicast stopping .. please help!

Hi All,

I hope i'm not missing somthing simple, as my setup isn't that complicated but i'm a fairly new to Cisco and Multicast configurations. But please read ahead! And let me know your thoughts on what I'm trying to do.

Objective:

I'm working on a small/medium size LAN, hoping to have 1 AP. With say 10 or 15 wireless clients. Connected to a handful of wired devices to the AP, with 1 or 2 of them sending out IGMP Multicast. The 10 or 15 wireless clients may be subscribing to IGMPv2 or v3 Multicast. Any of the clients maybe disconnecting and re-connecting and the other devices should keep receiving multicast.

The Equipment & Setup:

Cisco Aironet 1262N. Currently running IOS 12.4(25d)JA. 3x 2.4Ghz Antennas. 3x 5Ghz Annnas.

2x SSIDs. Each one for each radio.

No VLANS being used. Although under 'show igmp snooping' 1 appears:

CiscoAP1262>show ip igmp snooping

Global IGMP Snooping configuration:

-----------------------------------

IGMP snooping             : Enabled

IGMPv3 snooping (minimal) : Enabled

Report suppression        : Disabled

TCN solicit query         : Disabled

TCN flood query count     : 10

Vlan 1:

--------

IGMP snooping                       : Disabled

IGMPv2 immediate leave              : Disabled

Explicit host tracking              : Enabled

Multicast router learning mode      : cgmp

DHCP Server Enabled.

No encryption on either of the SSIDs.

Issue:

Currently Multicast (IGMPv2 and v3) is flowing nicely from my wired connected device (sending multicast on 239.0.1.1) to my wireless clients. But I find that the multicast performance goes down when I connect then disconnect a wireless client. As if the AP is still trying to communicate with the disconnected device. But if I disconnect a client, re-connect, then disconnect one more time I find that multicast has stopped flowing on all devices! It nearly always seems to happen after I disconnect one of my wireless clients twice.

What I've tried so far:

I've tried to turn on debug igmp snooping, but it doesn't show up much unless I have IGMP snooping enabled globally and on VLAN1 (which I don’t believe I’m using). But then if I enable IGMP snooping globally and the VLAN, multicast doesn't appear. So I get debug, but no multicast to compare the debug to.

I assumed my issue could be about TCN, so I've tried enabling and disabling TCN solicit query, and tried changing the flood query. But no combination seem to have any effect on my issue.

I also tried using the VLAN, so switching off global IGMP snooping and enabling it for VLAN1. Then tried IGMPv2 immediate leave on or off, and learn mode from ccgm to pim-dvmrp but still no change in my issue.

I've also tried creating some filters, and prioritising multicast. But that didn't appear to help, so I've switched that off.

Also enabled WiFi Multimedia.

And switched the data rates to 'Require' on my radios, to enable both uni and multicast packets at as many data rates as I can.

I’ve stopped using VLANs, as I don’t need to. And uploaded my config attached to this thread.

If anyone can help in anyway, I would really appreciate it.

AndyH

Everyone's tags (5)
1169
Views
0
Helpful
0
Replies
CreatePlease login to create content