Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AP 1231G Not Passing DHCP to clients

Hello  My company AP 1231G is not passing the DHCP address to the client from the DHCP server  can you please advise on my config listed below

basicly the AP is on its own VLAN 10.1.123.1 and the DHCP server is 10.1.10.2 -- trying to use iphelper to pass DHCP to clients and the AP is on static IP 10.1.123.2--

!

! Last configuration change at 13:15:56 +0800 Fri May 25 2012 by root

! NVRAM config last updated at 13:15:56 +0800 Fri May 25 2012 by root

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname XXXXXXXXXX

!

!

clock timezone +0800 8

ip subnet-zero

no ip domain lookup

ip domain name XXXXXXXXXXXXX

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

aaa session-id common

dot11 syslog

!

dot11 ssid XXXXXXXXXX

   authentication open

   authentication key-management wpa

   guest-mode

   infrastructure-ssid optional

   wpa-psk ascii XXXXXXXXXXXXXXXXXXXXXXX

!

dot11 arp-cache optional

!

!

username root privilege 15 password XXXXXXXXXXXXXXXXXXXXX

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm tkip

!

ssid XXXXXXXXXXX

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

no preamble-short

channel 2432

station-role root access-point

no dot11 extension aironet

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.1.123.2 255.255.255.0

ip helper-address 10.1.10.2

!

ip default-gateway 10.1.123.1

ip http server

ip http authentication aaa

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

access-list 111 permit tcp any any neq telnet

snmp-server view dot11view ieee802dot11 included

snmp-server view ieee802dot11 ieee802dot11 included

snmp-server community public RO

snmp-server community private view undefined RW

bridge 1 route ip

!

!

!

line con 0

terminal-type teletype

line vty 0 4

terminal-type teletype

!

sntp server 114.80.81.13

sntp broadcast client

end

Everyone's tags (6)
1 REPLY

AP 1231G Not Passing DHCP to clients

Roan:
Where is your DHCP server configured (swtich, firewall, 3rd party server..etc)?
Does it work correctly if the AP IP on same subnet  and ip-helper is not being utilized?

Rating useful replies is more useful than saying "Thank you"
800
Views
0
Helpful
1
Replies
CreatePlease login to create content