Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

AP 1242AG - Bridge Association BIG Strange Problem ?!

Hi !

I've got a problem with Cisco Access Point 1242AG.

MODEL : Cisco AIR-AP1242AG-E-K9.

IOS : C1240-K9W7-M version 12.4(10b)JA release software (fc2).

I would like to design this topology :

PC1---[AP1]* * *[AP2]---PC2

AP1 is "ROOT BRIDGE" (called GAUCHE in my cfg) and AP2 is "NON-ROOT BRIDGE" (called DROITE in my cfg).

I made my own configuration, but It doesn't work.

Here is the problem :

1) When the access point are powered up, they cannot associate. I have these error messages :

From AP1 :

==========

GAUCHE#

GAUCHE#Selected country Belgium

*Mar 1 00:10:51.406: %DOT11-6-ASSOC: Interface Dot11Radio0, Station DROITE 0022

.bdxx.xxxx Associated KEY_MGMT[NONE]

*Mar 1 00:10:52.468: %DOT11-4-MAXRETRIES: Packet to client 0022.bdxx.xxxx reach

ed max retries, removing the client

*Mar 1 00:10:52.468: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating

Station 0022.bdxx.xxxx Reason: Previous authentication no longer valid

*Mar 1 00:10:52.474: %DOT11-4-MAXRETRIES: Packet to client 0022.bdxx.xxxx reach

ed max retries, removing the client

From AP2 :

==========

DROITE>

*Mar 1 00:00:11.923: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to down

*Mar 1 00:00:22.953: %DOT11-4-CANT_ASSOC: Interface Dot11Radio0, cannot associate: No Response

DROITE>

2) If I switch the AP2 from "NON-ROOT BRIDGE" to "WORKGROUP-BRIDGE", the Access Points are associating themself, and I get these messages :

From AP1 :

==========

GAUCHE#

*Mar 1 00:12:48.087: %DOT11-6-ASSOC: Interface Dot11Radio0, Station DROITE 001d

.70xx.xxxx Associated KEY_MGMT[NONE]

GAUCHE#

From AP2 :

==========

DROITE(config-if)#

DROITE(config-if)#

*Mar 1 00:02:09.006: %DOT11-4-UPLINK_ESTABLISHED: Interface Dot11Radio0, Associated To AP GAUCHE 0022.bdxx.xxxx [None]

*Mar 1 00:02:09.008: %LINK-3-UPDOWN: Interface Dot11Radio0, changed state to up

*Mar 1 00:02:10.008: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to up

3) After this, I switch again the AP2 from "WORKGROUP-BRIDGE" to "NON-ROOT BRIDGE" and the association stay ...

I Get these messages :

From AP1 :

==========

GAUCHE#

GAUCHE#

*Mar 1 00:14:01.251: %DOT11-4-MAXRETRIES: Packet to client 001d.70xx.xxxx reach

ed max retries, removing the client

*Mar 1 00:14:01.251: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating

Station 001d.70xx.xxxx Reason: Previous authentication no longer valid

*Mar 1 00:14:01.258: %DOT11-4-MAXRETRIES: Packet to client 001d.70xx.xxxx reach

ed max retries, removing the client

*Mar 1 00:14:08.010: %DOT11-6-ASSOC: Interface Dot11Radio0, Station DROITE 0022

.bdxx.xxxx Associated KEY_MGMT[NONE]

From AP2 :

==========

DROITE(config-if)#

DROITE(config-if)#station-role non-root bridge

DROITE(config-if)#

*Mar 1 00:03:21.482: %LINK-3-UPDOWN: Interface Dot11Radio0, changed state to down

DROITE(config-if)#

*Mar 1 00:03:21.484: %LINK-5-CHANGED: Interface Dot11Radio0, changed state to reset

*Mar 1 00:03:22.482: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to down

*Mar 1 00:03:28.929: %DOT11-4-UPLINK_ESTABLISHED: Interface Dot11Radio0, Associated To AP GAUCHE 0022.bdxx.xxxx [None]

*Mar 1 00:03:28.930: %LINK-3-UPDOWN: Interface Dot11Radio0, changed state to up

*Mar 1 00:03:29.930: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to up

DROITE(config-if)#

If I reload the Access Points, they lost association, and they cannot associate again... I need to do the "non-root bridge to Workgroup-bridge to non-root bridge" switching manually before having association again.

Do you know if It's a BUG ?

Do you know how I can resolve this ?

I Join in attachments my configurations...

AP1 is "GAUCHE"

AP2 is "DROITE"

Thanks in advance.

2 REPLIES
Silver

Re: AP 1242AG - Bridge Association BIG Strange Problem ?!

Check the staleout time setting on the Configuration. If the same devices are always connected to the Workgroup Bridge, enter 5 for the staleout time setting. If the devices connected to the Workgroup Bridge change frequently, enter 300 (equal to five minutes) for the staleout time setting. If you disconnect the Ethernet cable from the workgroup bridge and reconnect it, the Workgroup Bridge removes all devices from its association table and relearns them, regardless of the staleout time setting.

New Member

Re: AP 1242AG - Bridge Association BIG Strange Problem ?!

Hi !

Thanks for your answer.

But, the problem, is that I don't want to make Workgroup Bridge !

I just use Workgroup Bridge cmd to up the wireless association link.

But I found another way...

When I remove all "Antenna" cmd, like :

"Antenna recieve right"

"Antenna transmit right"

"Antenna gain 15"

and then, I put them again, the link associations comes up again too...

Is there any problem with my configs ?

738
Views
0
Helpful
2
Replies
CreatePlease to create content