Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Silver

AP1130 Not Connecting to the WLC

Hello,

I have the access points set behind a DMZ interface on the firewall. The WLC and DHCP server are on the inside. I have enabled DHCP relay on the ASA. On the DHCP I have configured the scope for the APs along with option 43. The issue is that the APs are getting the IP address from the DHCP and I can see that in the leases but they never try to register to the WLC. I did enable LWAP debugging and I see nothing related to LWAP. I enbaled DHCP debugging and I can see the below only.

Remarks:

- Everything is allowed from AP subnet to the WLC and DHCP. I connected my laptop and set it on the APs VLAN and I was able to get an IP address and ping/telnet/https to the WLC.

I appreciate any help,

Thanks in advance,

Tue Mar 4 19:44:58 2008: 00:50:56:88:6b:e8 dhcpProxy: Received packet: Client 00:50:56:88:6b:e8

DHCP Op: BOOTREQUEST(1), IP len: 300, switchport: 0, encap: 0x0

Tue Mar 4 19:44:58 2008: 00:50:56:88:6b:e8 dhcp option len, including the magic cookie = 64

Tue Mar 4 19:44:58 2008: 00:50:56:88:6b:e8 dhcp option: received DHCP INFORM msg

Tue Mar 4 19:44:58 2008: 00:50:56:88:6b:e8 dhcp option: skipping option 61, len 7

Tue Mar 4 19:44:58 2008: 00:50:56:88:6b:e8 dhcp option: skipping option 12, len 11

Tue Mar 4 19:44:58 2008: 00:50:56:88:6b:e8 dhcp option: vendor class id = MSFT 5.0 (len 8)

Tue Mar 4 19:44:58 2008: 00:50:56:88:6b:e8 dhcp option: skipping option 55, len 12

Tue Mar 4 19:44:58 2008: 00:50:56:88:6b:e8 dhcpParseOptions: options end, len 64, actual 64

Tue Mar 4 19:44:58 2008: 00:50:56:88:6b:e8 dhcpProxy: Dropping packet (no mscb) from STA 00:50:56:88:6b:e8, giaddr:0.0.0.0, udpSrcPort:68, op:1

8 REPLIES
Silver

Re: AP1130 Not Connecting to the WLC

Any ideas plz?

Community Member

Re: AP1130 Not Connecting to the WLC

As a precaution, you might want to check the part number on the AP and make sure that it is an LWAP and not IOS version. You won't see any LLWAP traffic if it is running IOS. I had installed several before I found that the wrong part number was ordered. If that is the case, you can use the upgrade tool to convert them to LWAP.

Hope that is all that it is.

Community Member

Re: AP1130 Not Connecting to the WLC

m-haddad - Could you run "debug lwapp events enable" on your controller and paste the output here? I'd like to see if the controller even sees discover/join requests from the AP.

Re: AP1130 Not Connecting to the WLC

Layer 3 uses UDP 12222 12223 for communication... are these open!?

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
___________________________________________________________
Silver

Re: AP1130 Not Connecting to the WLC

Hello All,

Thanks for all the feedbacks. It turned out that the DHCP is configured with the WLC management IP instead of the WLC AP-MAnager IP.

I have another issue which will cause the deployment to be a complete failure if not achieved and below you can find the description:

have a WCS,WLC and LOC deployed. The integration betwen the WLC and WCS is working perfectly. We didn't put a lot of access points in the deployment because we didn't need acurate location tracking but at least we need some.

The problem is the location appliance is not able to pull any information about the connected clients. No clients shows on the map eventhough the APs report connected clients.

One issue I had is when I try to synchronize the network design with the location appliance I get the below error:

"Element found and will be pulled to WCS".

I appreciate any help with issue as it is quite urgent,

Community Member

Re: AP1130 Not Connecting to the WLC

Was this ever fixed?

This might be a fix...ifthis was overlooked. It stumped me for a while but after stumbling around it worked for me.

If you are using WCS...

Go to Location Servers:

Click on your Location Server:

Go to Administration/ Tracking Parameters:

Make sure you have enabled Client Stations as a trackable item;

Save it.

Silver

Re: AP1130 Not Connecting to the WLC

It turned out two issues:

1- ACL was denying traffic

2- I had the WLC wrong IP address in the DHCP. It has to be the AP Manager IP address.

Hope this helps,

Regards,

Community Member

Re: AP1130 Not Connecting to the WLC

Thanks m-haddad,

We just had the same DHCP interface issue on Friday installing a new controller. Ironic! :)

660
Views
2
Helpful
8
Replies
CreatePlease to create content