Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

AP1230B Upgrade problem

I have a AIR-AP1230B-E-K9 access point, which worked fine in its original hardware configuration, which included an AIR-MP20B mini-PCI radio module (802.11b standard).

I decided I wanted to upgrade it to be a dual wireless, 2.4Ghz and 5Ghz access point and so I installed an AIR-RM21A-E-K9 module.

At the same time, I upgraded the IOS to C1200 Software (C1200-K9W7-M), Version 12.3(8)JEA and the access point worked fine and supported both 802.11b and 802.11a.

I wanted to increase the throughput of the 2.4Ghz radio and so decided to install an AIR-MP21G-A-K9 upgrade module, which should enable 802.11g compatability.

However when I boot the AP, I get the following error message:

Mar 6 19:40:25.109: %DOT11-2-NO_FIRMWARE: Interface Dot11Radio0, no radio firmware file (flash:/c1200-k9w7-mx.123-8.JEA/5501.img) was found

Mar 6 19:40:25.111: %DOT11-2-NO_FIRMWARE: Interface Dot11Radio0, no radio firmware file (flash:/5501.img) was found

Mar 6 19:40:25.112: %DOT11-2-RESET_RADIO: Interface Dot11Radio0, Radio firmware file not found, Trying hardware reset on radio

It appears that the radio firmware file "5501.img" is missing from the IOS image!

I've tried downloading several of the older IOS image files and un-tar'd them, but none of them seem to contain the "5501.img" file.

I've read all the associated documents relating to the AP1200 and as far as I can see, it should support this 802.11g and 802.11a configuration, so where am I going wrong?

Could someone please explain how to resolve this issue or why this configuration is not supported?

Thanks

7 REPLIES
Hall of Fame Super Red

Re: AP1230B Upgrade problem

Hi Dominic,

Here is a very similar thread from last December. It seems that the new Radio module (with none of the identifying stickers) may have been intended for the wrong country (ETSI or Japan) Have a look;

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=Getting%20Started%20with%20Wireless&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddcff38/7#selected_message

Hope this helps! Please let us know your resolution :)

Rob

New Member

Re: AP1230B Upgrade problem

Hi Rob,

Thanks for your response. The previous thread is exactly the same symptoms that I've been experiencing.

My first thoughts, before reading that thread, was that the reason it wasn't working was that my AP is an AP1230B-E-K9 (i.e. a European model), however the show tech was reporting the mini-PCI as an American module (i.e. AIR-MP21G-A-K9):

------------------ show controllers ------------------

!

interface Dot11Radio0

Radio , Base Address 0000.0000.0000, BBlock version 0.00, Software version 0.00.0

Serial number:

Number of supported simultaneous BSSID on Dot11Radio0: 8

Carrier Set: Americas (US )

---------------------------

However, the fact that the radio module has no identifying stickers, which seems to be common amongst all those having problems, suggest to me that it is probably a cheap, inferior counterfit module.

I have contacted the reseller requesting a genuine AIR-MP21G-E-K9 (European module) and will await their response.

I feedback the outcome.

Cheers,

Dom

Hall of Fame Super Red

Re: AP1230B Upgrade problem

Hi Dom,

Yes, once you get the E - Module you should be good to go :)

Thanks for the feedback!

Rob

New Member

Re: AP1230B Upgrade problem

I am having the same issue on a 1220B to 1231G upgrade. How did you resolve the problem.

New Member

Re: AP1230B Upgrade problem

I am having the same issue on a 1310G. Any resolution? Odd thing is that it works on some of mine but not others from the same batch/serial numbers. Anything else it could be?

New Member

Re: AP1230B Upgrade problem

Do a 'show tech' and check the hardware versions of your 1310G. Check to see whether they are US or European versions.

New Member

Re: AP1230B Upgrade problem

It turned out that my upgrade module was a US module and not a European module. I purchased a European module and everything worked fine.

Make sure you purchase your module from an approved Cisco dealer.

Hope this helps.

369
Views
0
Helpful
7
Replies
CreatePlease to create content