Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AP1231 does not hand out DHCP IP to clients

I have an ap configured to handout DHCP to the wireless clients. This is what I see on the pix.

#debug ip dhcp server packet

*Mar 7 23:51:21.172: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 0009.5b83.47d6 Associated KEY_MGMT[WPA PSK]

*Mar 7 23:51:21.284: DHCPD: DHCPDISCOVER received from client 0100.095b.8347.d6 on interface BVI1.

*Mar 7 23:51:25.290: DHCPD: DHCPDISCOVER received from client 0100.095b.8347.d6 on interface BVI1.

*Mar 7 23:51:32.293: DHCPD: DHCPDISCOVER received from client 0100.095b.8347.d6 on interface BVI1.

*Mar 7 23:51:49.308: DHCPD: DHCPDISCOVER received from client 0100.095b.8347.d6 on interface BVI1.

The client never gets an IP. Here is my config. Thanks in advance!

#sh run

Building configuration...

Current configuration : 3800 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname widgets1

!

enable secret xxxx

enable password xxxx

!

username xxx privilege 15 password xxxx

ip subnet-zero

ip domain name

no ip dhcp conflict logging

ip dhcp excluded-address 10.4.1.240 10.4.1.254

!

ip dhcp pool widgets

network 10.4.1.0 255.255.255.0

default-router 10.4.1.254

lease 10

!

!

no aaa new-model

!

dot11 ssid widgets

authentication open

authentication key-management wpa

infrastructure-ssid optional

wpa-psk ascii xxxx

!

!

crypto ca trustpoint TP-self-signed-479015087

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-479015087

revocation-check none

rsakeypair TP-self-signed-479015087

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm tkip

!

ssid widgets

!

short-slot-time

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.1.1.1 255.255.255.0

no ip route-cache

!

ip default-gateway 10.1.1.254

no ip http server

ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

logging snmp-trap emergencies

logging snmp-trap alerts

logging snmp-trap critical

logging snmp-trap errors

logging snmp-trap warnings

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

access-class 111 in

transport preferred all

transport output all

line vty 0 4

access-class 111 in

login local

transport preferred all

transport input all

transport output all

line vty 5 15

access-class 111 in

login

transport preferred all

transport input all

transport output all

!

end

1 REPLY
New Member

Re: AP1231 does not hand out DHCP IP to clients

I think this is because your IP address 10.1.1.1/24 is on a different network to the IP DHCP scope 10.4.1.0/24. Try changing the IP DHCP pool to 10.1.1.0/24 and exclude any necessary addresses.

An alternative is to create multiple VLAN-SSID mappings so that you can use 10.1.1.1/24 for bvi 1 and 10.4.1.0/24 for the WLAN users in a seperate VLAN-SSID.

Hope this helps

134
Views
0
Helpful
1
Replies
CreatePlease login to create content