Cisco Support Community
Community Member

AP1310 IOS Problem

I currently have a CIsco 1310 which seems to have died. For some reason it wont boot. No bootable files found. When trying to TFTP an IOS to it I keep getting Invalid Argument. Can anyone please help me with what I might be doing wrong. Thanks in advance.

Community Member

Re: AP1310 IOS Problem

when using the ROM loader, you always have to prepend the "drive" (filesystem), it does not default to flash:

Also you have to set environment variables to give it an IP and gateway to reach the TFTP server.

Community Member

Re: AP1310 IOS Problem

So would this statement be correct?

tar -xtract tftp:// flash:

After tftp_init I enter the above command and it returns with invalid argument.

I am directly connected to it with a crossover cable, configured the 1310 with:




Laptop with :

Using Pumpkin as tftp server:

it hits the pumpkin server fine but as soon as I grant access to the file I get the Invalid Argument error.

Community Member

Re: AP1310 IOS Problem

That's the right statement, IIRC.

But the same file I have ends with a .tar. Are you sure that's not a directory where you've already unpacked the tar on the tftp server, and not the tar file you think it is?

Also check that your TFTP server actually requires the absolute "/tftp/" path and not just the filename.

(note you are missing a "1" if you cut and pasted that.)

Community Member

Re: AP1310 IOS Problem

No I typed it in (*reference the missing "1" in 1310) and I also forgot to type the ".tar" part (Actually tried it with and without it). I've typed it out in notepad and copy/pasted in the console. Did not do that for this post. Also I tried it with and without the "tftp" directory.

CreatePlease to create content