Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

APs with major software version than WLC

Hello,

We have a customer with two WLC.

Some APs are connected to the WLC-1 (4400 series) with software version 7.0, and the others to the WLC-2, (5500 series) same version.

Now we need to use 7.5 software version on the WLC-2 in order to use the newest AP families, not supported by 7.0 software version.

The problem is that the two WLC are in fallback mode....

In the event of the failure of WLC-1, the APs connected to it will associate to WLC-2, and a consequent software upgrade will occur.

Then what will happens when the WLC-1 will come back online? The APs will still be able to fallback to it even they will have a major software version?

Thanks a lot.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: APs with major software version than WLC

You shouldn't fallback to WLC with different versions. Keep the AP's on the WLC it primary to and then upgrade the 4400 to a 5508. That is the only way. If you want redundancy, wlc's has to have the same code or else it can get messy.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
5 REPLIES
Hall of Fame Super Silver

Re: APs with major software version than WLC

You shouldn't fallback to WLC with different versions. Keep the AP's on the WLC it primary to and then upgrade the 4400 to a 5508. That is the only way. If you want redundancy, wlc's has to have the same code or else it can get messy.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
Community Member

APs with major software version than WLC

Hello Scott,

Thanks, but I can't figure out to to this.

I've made different mobility groups, no secondary WLC entries in the APs joined to WLC-1 etc...

WLC-2 completely removed in every entries of WLC-1 APs, but still in every case, if I reboot WLC-1 the APs wil lfind WLC-2

THanks again.

Hall of Fame Super Silver

Re: APs with major software version than WLC

Well the AP must of learned the other WLC IP address somehow. Maybe you had mobility before or your using option 43 or DNS. If the AP's are on the same subnet as the WLC, then later 2 broadcast is another way the AP's find a WLC. You can enable AAA authentication for access points. This is a workaround though.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
VIP Purple

Re: APs with major software version than WLC

APs will remember all previously known WLCs in NVRAM. So even if you delete HA parameters it will not remove previously known WLC from its memory. Therefore if a controller not available it will try to register with all known controller. So it will find your other controller.

You can erase these information from AP by using "erase /all nvram:" on AP console (previledge mode). Test with one AP & see

HTH

Rasika

**** Pls rate all useful responses ****

Re: APs with major software version than WLC

I would also add, make sure the controllers aren't in the same mobility group. If you delete a config from an ap, once it joins the controller it will learn all the controllers in the domain group ..

Sent from Cisco Technical Support iPad App

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
___________________________________________________________
175
Views
9
Helpful
5
Replies
CreatePlease to create content