Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Assistance setting up wifi with Cisco 891c

Hi, bellow is a AP current configuration, this is one of mine remote locations so i am relying on users' eyes on the field.

It is brand new setup, the issue is: user is able to see wireless SSID but when try to connect nothing is happening, laptop is trying to establish the connection with AP but it just timed out, no prompt for username/password needed to authenticate.

I am positive it is some simple config step that is missing so if someone point me in the right direction would be very appreciated.

Regards

AP Config:

rba-bei-ap1#sh run

Building configuration...

Current configuration : 3481 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname rba-bei-ap1

!

!

no aaa new-model

no ip domain lookup

!

!

dot11 syslog

!

dot11 ssid RBAWIFI

   vlan 81

   authentication client username USERNAME password 0 PASSWORD

   guest-mode

!

!

crypto pki trustpoint TP-self-signed-4056863392

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-4056863392

revocation-check none

rsakeypair TP-self-signed-4056863392

!

!

crypto pki certificate chain TP-self-signed-4056863392

certificate self-signed 01

  30820243 308201AC A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 34303536 38363333 3932301E 170D3032 30333032 31383338

  34355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 30353638

  36333339 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100B8DC 41005B88 ECF038F3 87DFEAC0 93AE557B 903D1163 C06C1D20 B9915030

  BAE712F9 F9E9F9B7 E9FE132E E00B1CEC A415AF41 BA5588DB A4030BCB EF2FBEF5

  43FE61BE 4514B304 C27F1517 D7E95DFB 6C74D035 26CB1B81 38CC7475 4799E098

  A01CCF82 A8F0E8A9 E5E9ABC1 7AD3BD22 B7023BE8 14E72EED 8046EDFB 7C7E064C

  90D50203 010001A3 6B306930 0F060355 1D130101 FF040530 030101FF 30160603

  551D1104 0F300D82 0B726261 2D626569 2D617031 301F0603 551D2304 18301680

  146FC6BA D81F6640 A36E5242 D2BEDAEF 79D1FA15 F8301D06 03551D0E 04160414

  6FC6BAD8 1F6640A3 6E5242D2 BEDAEF79 D1FA15F8 300D0609 2A864886 F70D0101

  04050003 818100AA 0079CC96 A9082997 87F40E05 C5CD5601 0D683338 38066162

  D156380A 73DFE08B 10B74B9C 0CA070DF CF63E6B8 07E43F4A F60F4AE5 CCDDDEE7

  E09E5979 FDE4EC8E 742BA541 3DDA06B7 66B573A7 284CCC0E 01AC9EA5 CE94B6DE

  AC86B152 5B1907D0 797DF6BF 460572FF 5217EF2C 32608FED F4D543C8 D365A217

  9624A217 AAE70E

  quit

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

ssid RBAWIFI

!

antenna gain 0

station-role root

!

interface Dot11Radio0.81

encapsulation dot1Q 81 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.112.156.2 255.255.255.0

no ip route-cache

!

ip http server

ip http authentication local

ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!        

line con 0

privilege level 15

login local

no activation-character

line vty 0 4

login local

!

end

Everyone's tags (4)
10 REPLIES

Assistance setting up wifi with Cisco 891c

what you have configured now would be for if the AP needed to authenticate to the network as a client.

Are you wanting to have your users just have a PSK, or do you want them to use domain credentials?

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Assistance setting up wifi with Cisco 891c

Hi Stephen, thanks for quick responce.

i need users to type in configured username (USERNAME) and password (PASSWORD) in order to connect and use configured wifi; no domain credentials.

"dot11 ssid RBAWIFI

   vlan 81

   authentication client username USERNAME password 0 PASSWORD"

Assistance setting up wifi with Cisco 891c

What type of clients are you going to have?  can they support LEAP or EAP-Fast?  Those are the only methods avaiable when you use the AP as the AAA server.

If you have IAS/NPS/ACS you can do PEAP.

I'll work up a config that will work if you can do EAP-Fast, with the user/pass you want them to use.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Assistance setting up wifi with Cisco 891c

ACS would be a bit tricky at this point. Need to provide a Internet access over wireless (built in AP into router 891) to my users at the location.

Would you be able to provide me with some configration steps for EAP-Fast?

Assistance setting up wifi with Cisco 891c

Take a look at the guide below.

http://www.cisco.com/en/US/docs/wireless/access_point/12.3_2_JA/configuration/guide/s32local.html

Though if you are just wanting to internet access, PSK would be easier, for both you and the users.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Assistance setting up wifi with Cisco 891c

Hi,

Here is recent AP config, not sure what is going on but i am unable to see the wifi nor to connect. Any ideas where to go from here? Realy appreciated.

rba-bei-ap1# sh ip int br

Interface                  IP-Address      OK? Method Status                Protocol

BVI1                       10.112.156.2    YES NVRAM  up                    up     

Dot11Radio0                unassigned      YES NVRAM  reset                 down   

Dot11Radio0.81             unassigned      YES unset  reset                 down   

Dot11Radio1                unassigned      YES NVRAM  reset                 down   

GigabitEthernet0           unassigned      YES NVRAM  up                    up     

rba-bei-ap1#

rba-bei-ap1#sh run

Building configuration...

Current configuration : 3540 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname rba-bei-ap1

!

!

no aaa new-model

no ip domain lookup

!

!

dot11 syslog

!

dot11 ssid RBAWIFI

   authentication open

   authentication key-management wpa

   wpa-psk ascii 0 SecretKey

!

!

crypto pki trustpoint TP-self-signed-4056863392

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-4056863392

revocation-check none

rsakeypair TP-self-signed-4056863392

!

!

crypto pki certificate chain TP-self-signed-4056863392

certificate self-signed 01

  30820243 308201AC A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 34303536 38363333 3932301E 170D3032 30333032 31383338

  34355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 30353638

  36333339 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100B8DC 41005B88 ECF038F3 87DFEAC0 93AE557B 903D1163 C06C1D20 B9915030

  BAE712F9 F9E9F9B7 E9FE132E E00B1CEC A415AF41 BA5588DB A4030BCB EF2FBEF5

  43FE61BE 4514B304 C27F1517 D7E95DFB 6C74D035 26CB1B81 38CC7475 4799E098

  A01CCF82 A8F0E8A9 E5E9ABC1 7AD3BD22 B7023BE8 14E72EED 8046EDFB 7C7E064C

  90D50203 010001A3 6B306930 0F060355 1D130101 FF040530 030101FF 30160603

  551D1104 0F300D82 0B726261 2D626569 2D617031 301F0603 551D2304 18301680

  146FC6BA D81F6640 A36E5242 D2BEDAEF 79D1FA15 F8301D06 03551D0E 04160414

  6FC6BAD8 1F6640A3 6E5242D2 BEDAEF79 D1FA15F8 300D0609 2A864886 F70D0101

  04050003 818100AA 0079CC96 A9082997 87F40E05 C5CD5601 0D683338 38066162

  D156380A 73DFE08B 10B74B9C 0CA070DF CF63E6B8 07E43F4A F60F4AE5 CCDDDEE7

  E09E5979 FDE4EC8E 742BA541 3DDA06B7 66B573A7 284CCC0E 01AC9EA5 CE94B6DE

  AC86B152 5B1907D0 797DF6BF 460572FF 5217EF2C 32608FED F4D543C8 D365A217

  9624A217 AAE70E

  quit

!        

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers tkip

!

ssid RBAWIFI

!

antenna gain 0

station-role root

!

interface Dot11Radio0.81

encapsulation dot1Q 81 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router

no ip address

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.112.156.2 255.255.255.0

no ip route-cache

!

ip default-gateway 10.112.156.1

bridge 1 route ip

!        

!

!

line con 0

privilege level 15

login local

no activation-character

line vty 0 4

login local

!

end

Re: Assistance setting up wifi with Cisco 891c

To see the SSID you will want to add the command. Guest-mode under the SSID config.

You should ASAP do a no interface dot11radio0.81. Then

interface dot11rafio0

Bridge-group 1

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: Assistance setting up wifi with Cisco 891c

OK here we go, would this config be enough? Sorry for all these questions but i am working on remote router so have no way of testing it myself.

Any good link for troubleshooting commands - like to see if this wifi network is broadcasting or not from cli

Appreciate your assistance.

rba-bei-ap1#sh run
Building configuration...

Current configuration : 3477 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname rba-bei-ap1
!
!
no aaa new-model
no ip domain lookup
!
!
dot11 syslog
!
dot11 ssid RBAWIFI
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 0 SecretKey!
!
crypto pki trustpoint TP-self-signed-4056863392
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4056863392
revocation-check none
rsakeypair TP-self-signed-4056863392
!
!
crypto pki certificate chain TP-self-signed-4056863392
certificate self-signed 01
  30820243 308201AC A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34303536 38363333 3932301E 170D3032 30333032 31383338
  34355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 30353638
  36333339 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B8DC 41005B88 ECF038F3 87DFEAC0 93AE557B 903D1163 C06C1D20 B9915030
  BAE712F9 F9E9F9B7 E9FE132E E00B1CEC A415AF41 BA5588DB A4030BCB EF2FBEF5
  43FE61BE 4514B304 C27F1517 D7E95DFB 6C74D035 26CB1B81 38CC7475 4799E098
  A01CCF82 A8F0E8A9 E5E9ABC1 7AD3BD22 B7023BE8 14E72EED 8046EDFB 7C7E064C
  90D50203 010001A3 6B306930 0F060355 1D130101 FF040530 030101FF 30160603
  551D1104 0F300D82 0B726261 2D626569 2D617031 301F0603 551D2304 18301680
  146FC6BA D81F6640 A36E5242 D2BEDAEF 79D1FA15 F8301D06 03551D0E 04160414
  6FC6BAD8 1F6640A3 6E5242D2 BEDAEF79 D1FA15F8 300D0609 2A864886 F70D0101
  04050003 818100AA 0079CC96 A9082997 87F40E05 C5CD5601 0D683338 38066162
  D156380A 73DFE08B 10B74B9C 0CA070DF CF63E6B8 07E43F4A F60F4AE5 CCDDDEE7
  E09E5979 FDE4EC8E 742BA541 3DDA06B7 66B573A7 284CCC0E 01AC9EA5 CE94B6DE
  AC86B152 5B1907D0 797DF6BF 460572FF 5217EF2C 32608FED F4D543C8 D365A217
  9624A217 AAE70E
  quit
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers tkip
!
ssid RBAWIFI
!
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!        
interface Dot11Radio1
no ip address
no ip route-cache
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
no ip address
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 10.112.156.2 255.255.255.0
no ip route-cache
!
ip default-gateway 10.112.156.1
bridge 1 route ip
!
!
!
line con 0
privilege level 15
login local
no activation-character
line vty 0 4
login local
!
end

rba-bei-ap1# 

Re: Assistance setting up wifi with Cisco 891c

Yup that should work

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Bronze

Re: Assistance setting up wifi with Cisco 891c

Hi,

Yes configuration should work.

876
Views
0
Helpful
10
Replies